summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-26 06:13:55 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-26 06:13:55 +0000
commit6b37b13709e52e8a1bf0b2756fcad97871638243 (patch)
treebcd8d7155170f27314d0351c0d432e45aad53252 /app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild
parentUnwanted commit (diff)
downloadhistorical-6b37b13709e52e8a1bf0b2756fcad97871638243.tar.gz
historical-6b37b13709e52e8a1bf0b2756fcad97871638243.tar.bz2
historical-6b37b13709e52e8a1bf0b2756fcad97871638243.zip
New package. (#1607)
Diffstat (limited to 'app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild')
-rw-r--r--app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild b/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild
new file mode 100644
index 000000000000..9a3b89fd20dc
--- /dev/null
+++ b/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Preston A. Elder <prez@goth.net>
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild,v 1.1 2002/04/26 06:13:55 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Modules that add encryption ability at the kernel level."
+SRC_URI="http://prdownloads.sourceforge.net/cryptoapi/${P}.tar.gz"
+HOMEPAGE="http://www.sourceforge.net/projects/cryptoapi"
+
+DEPEND=">=sys-apps/util-linux-2.11o-r2
+ sys-kernel/linux-sources"
+
+src_compile() {
+ econf || die
+ cd ${S}/api
+ cp Makefile Makefile.orig
+ sed -e "s:-DMODVERSIONS:-DMODVERSIONS -DEXPORT_SYMTAB:g" \
+ Makefile.orig >Makefile
+ cd ..
+ cp config.status config.status.orig
+ sed -e "s:-DMODVERSIONS:-DMODVERSIONS -DEXPORT_SYMTAB:g" \
+ config.status.orig >config.status
+ emake || die
+}
+
+src_install() {
+ dodir /lib/modules/misc
+ make MODLIB=${D}/lib/modules/misc \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL LICENSE.crypto
+ dodoc NEWS README* TODO doc/* doc/utils/*
+}
+
+pkg_postinst() {
+ einfo " "
+ einfo "Please add cryptoloop to your /etc/modules.autoload."
+ einfo "If you would like to enable the module now:"
+ einfo " depmod"
+ einfo " modprobe cryptoloop"
+ einfo " "
+}