summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-31 13:11:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-31 13:11:26 +0000
commit781ac36e8232fc3cbbcf24b5a4f992f4e2153e6c (patch)
tree6767df75c220159fd8ba298eb86ec88ffeef4564 /app-arch
parentinitial import (diff)
downloadhistorical-781ac36e8232fc3cbbcf24b5a4f992f4e2153e6c.tar.gz
historical-781ac36e8232fc3cbbcf24b5a4f992f4e2153e6c.tar.bz2
historical-781ac36e8232fc3cbbcf24b5a4f992f4e2153e6c.zip
handle openbsd CHOSTs as well
Package-Manager: portage-2.1_pre3
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/Manifest10
-rw-r--r--app-arch/unzip/unzip-5.52-r1.ebuild3
-rw-r--r--app-arch/unzip/unzip-5.52.ebuild3
3 files changed, 9 insertions, 7 deletions
diff --git a/app-arch/unzip/Manifest b/app-arch/unzip/Manifest
index 8766e602d37b..cca060f5f8e5 100644
--- a/app-arch/unzip/Manifest
+++ b/app-arch/unzip/Manifest
@@ -9,12 +9,12 @@ MD5 3b01796cbe10d9492bd8c0825bc83544 files/unzip-5.50-dotdot.patch 3236
MD5 b17d0181200f3e1f47a55b54eb93527d files/unzip-5.52-no-exec-stack.patch 334
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 4c9cca80bd3bde938e8921913622b498 unzip-5.50-r2.ebuild 1129
-MD5 7788e8d3d98f2a6f514542ab343a6fe3 unzip-5.52-r1.ebuild 1389
-MD5 4c3106ff7fd92dd5965a51baa9195a3e unzip-5.52.ebuild 1327
+MD5 9e1a148016d7e49d5970cb077104206e unzip-5.52-r1.ebuild 1423
+MD5 6931e50583dc5da981c8d00036871820 unzip-5.52.ebuild 1361
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDtn982+ySkm8kpY0RAhjeAKCwJEWFdzvgYfq3dbc/wJsimzyuegCfZ6sg
-g+y8GKy93SA7P9Zkv3iDQ5A=
-=ouzq
+iD8DBQFDtoOn2+ySkm8kpY0RAkaQAJwI1BtpoHeTaJyEerkyPXJiXhAY+ACfWyPC
++ZA+XpcgNPQ7m7lwQR9KBf4=
+=Wdqb
-----END PGP SIGNATURE-----
diff --git a/app-arch/unzip/unzip-5.52-r1.ebuild b/app-arch/unzip/unzip-5.52-r1.ebuild
index 38aa53ee72ff..ec0a8d78c493 100644
--- a/app-arch/unzip/unzip-5.52-r1.ebuild
+++ b/app-arch/unzip/unzip-5.52-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.2 2005/12/31 12:53:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.3 2005/12/31 13:11:26 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -36,6 +36,7 @@ src_compile() {
i?86*-linux*) TARGET=linux_asm ;;
*-linux*) TARGET=linux_noasm ;;
*-freebsd*) TARGET=freebsd ;;
+ *-openbsd*) TARGET=openbsd ;;
*-darwin*) TARGET=macosx ;;
*) die "Unknown target, you suck" ;;
esac
diff --git a/app-arch/unzip/unzip-5.52.ebuild b/app-arch/unzip/unzip-5.52.ebuild
index d91c1581a65a..b1771edfe6eb 100644
--- a/app-arch/unzip/unzip-5.52.ebuild
+++ b/app-arch/unzip/unzip-5.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52.ebuild,v 1.11 2005/12/31 12:53:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52.ebuild,v 1.12 2005/12/31 13:11:26 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -35,6 +35,7 @@ src_compile() {
i?86*-linux*) TARGET=linux_asm ;;
*-linux*) TARGET=linux_noasm ;;
*-freebsd*) TARGET=freebsd ;;
+ *-openbsd*) TARGET=openbsd ;;
*-darwin*) TARGET=macosx ;;
*) die "Unknown target, you suck" ;;
esac