summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-06-02 21:27:33 +0000
committerDavid Holm <dholm@gentoo.org>2004-06-02 21:27:33 +0000
commit889c2c48ba4942c380fa8755eecabffe75fad92d (patch)
tree55b5e9ee7f64c478d0afab37801428d0f74599c7 /app-arch/macutil/macutil-2.0_beta3.ebuild
parentPPC stable profile update (diff)
downloadhistorical-889c2c48ba4942c380fa8755eecabffe75fad92d.tar.gz
historical-889c2c48ba4942c380fa8755eecabffe75fad92d.tar.bz2
historical-889c2c48ba4942c380fa8755eecabffe75fad92d.zip
Initial import
Diffstat (limited to 'app-arch/macutil/macutil-2.0_beta3.ebuild')
-rw-r--r--app-arch/macutil/macutil-2.0_beta3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-arch/macutil/macutil-2.0_beta3.ebuild b/app-arch/macutil/macutil-2.0_beta3.ebuild
new file mode 100644
index 000000000000..ab54fb88a1e1
--- /dev/null
+++ b/app-arch/macutil/macutil-2.0_beta3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/macutil-2.0_beta3.ebuild,v 1.1 2004/06/02 21:27:33 dholm Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${PN}"
+MY_P=${P/_beta/b}
+DESCRIPTION="A collection of programs to handle Macintosh files/archives on non-Macintosh systems"
+SRC_URI="ftp://ftp.cwi.nl/pub/dik/${MY_P/-/}.shar.Z"
+HOMEPAGE="http://homepages.cwi.nl/~dik/english/ftp.html"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ~ppc"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ unshar ${MY_P/-/}.shar
+ cd ${PN}
+
+ sed -i.orig \
+ -e "s:CF =\t\(.*\):CF = \1 $CFLAGS:g" \
+ -e "s:-DBSD::g" \
+ -e "s:-DDEBUG::g" \
+ -e "s:/ufs/dik/tmpbin:$D/usr/bin:g" \
+ makefile
+}
+
+src_compile() {
+ emake || die "build failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ einstall || die "install failed"
+
+ doman man/*.1
+ dodoc README doc/*
+}