summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-17 16:56:08 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-17 16:56:08 +0000
commit73c7f77c36fbc18eff7422e9d0d677f481606f7f (patch)
tree29340cde5e3724a879d69e52ce426e27a1d04172 /app-arch/guitar
parentmarked ~ppc64; bug #55691 (diff)
downloadhistorical-73c7f77c36fbc18eff7422e9d0d677f481606f7f.tar.gz
historical-73c7f77c36fbc18eff7422e9d0d677f481606f7f.tar.bz2
historical-73c7f77c36fbc18eff7422e9d0d677f481606f7f.zip
clean up ugly ugly ebuild
Diffstat (limited to 'app-arch/guitar')
-rw-r--r--app-arch/guitar/Manifest12
-rw-r--r--app-arch/guitar/guitar-0.1.4.ebuild20
2 files changed, 19 insertions, 13 deletions
diff --git a/app-arch/guitar/Manifest b/app-arch/guitar/Manifest
index 0caab88d1003..d52820f73b5b 100644
--- a/app-arch/guitar/Manifest
+++ b/app-arch/guitar/Manifest
@@ -1,4 +1,14 @@
-MD5 f36f9dc6223c8f79fc457ddb3d9f5c6a guitar-0.1.4.ebuild 974
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 8ff58f88ce8599a3af05985ec544930f ChangeLog 1517
+MD5 6dcd8f1d430999877dbc6c7f4c9d592a guitar-0.1.4.ebuild 856
MD5 dab7696b5e040e412f887980f226db23 files/digest-guitar-0.1.4 64
MD5 8ae679e723d206b50b88118dc6bebb52 files/install.gnome 495
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBm4LZHTu7gpaalycRAkLZAJ9/Qr0TOLaIrlbsyuy+Bh9CgZ0r1ACdFrDW
+EaOblc+DSPPYn4nkFn3DfBc=
+=iW/P
+-----END PGP SIGNATURE-----
diff --git a/app-arch/guitar/guitar-0.1.4.ebuild b/app-arch/guitar/guitar-0.1.4.ebuild
index 145f584ed964..59c03b68a672 100644
--- a/app-arch/guitar/guitar-0.1.4.ebuild
+++ b/app-arch/guitar/guitar-0.1.4.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/guitar/guitar-0.1.4.ebuild,v 1.25 2004/08/20 21:08:29 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/guitar/guitar-0.1.4.ebuild,v 1.26 2004/11/17 16:56:08 vapier Exp $
MY_P=guiTAR-${PV}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="Extraction tool, supports the tar, tar.Z, tar.gz, tar.bz2, lha, lzh, rar, arj, zip, and slp formats."
-SRC_URI="http://artemis.efes.net/disq/guitar/${MY_P}.tar.gz"
+DESCRIPTION="Extraction tool, supports tar, tar.Z, tar.gz, tar.bz2, lha, lzh, rar, arj, zip, and slp formats"
HOMEPAGE="http://artemis.efes.net/disq/guitar/"
+SRC_URI="http://artemis.efes.net/disq/guitar/${MY_P}.tar.gz"
-IUSE="gnome"
-SLOT="0"
LICENSE="GPL-2"
-
-#app-arch/rar is binary for x86 only, how is sparc supported?
-KEYWORDS="x86 ppc ~amd64 -sparc"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="gnome"
DEPEND="=x11-libs/gtk+-1.2*
app-arch/tar
@@ -25,13 +23,11 @@ DEPEND="=x11-libs/gtk+-1.2*
app-arch/unzip"
src_compile() {
- local myconf
- use gnome || myconf="${myconf} --disable-gnome"
- econf ${myconf} || die "econf failed"
+ econf $(use_enable gnome) || die
emake || die
}
src_install() {
use gnome && cp ${FILESDIR}/install.gnome ${S}
- einstall
+ make install DESTDIR="${D}" || die
}