summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-11-20 17:28:10 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-11-20 17:28:10 +0000
commitef8bff867ddfa9d7fd6dfc9eb079365b26fd54ff (patch)
treeee9e413d0a21241bcf9087999eba466cfb34e6f2 /app-antivirus/vlnx/vlnx-4510e.ebuild
parentStable on amd64/x86 and removing older ebuilds since the older versions of NW... (diff)
downloadhistorical-ef8bff867ddfa9d7fd6dfc9eb079365b26fd54ff.tar.gz
historical-ef8bff867ddfa9d7fd6dfc9eb079365b26fd54ff.tar.bz2
historical-ef8bff867ddfa9d7fd6dfc9eb079365b26fd54ff.zip
Taked maintainership wrt bug 117650.
Version bump. Changed updater script wrt bug 117650. Package-Manager: portage-2.1.2_rc1-r4
Diffstat (limited to 'app-antivirus/vlnx/vlnx-4510e.ebuild')
-rw-r--r--app-antivirus/vlnx/vlnx-4510e.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-antivirus/vlnx/vlnx-4510e.ebuild b/app-antivirus/vlnx/vlnx-4510e.ebuild
new file mode 100644
index 000000000000..f10a6c96ffb4
--- /dev/null
+++ b/app-antivirus/vlnx/vlnx-4510e.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/vlnx/vlnx-4510e.ebuild,v 1.1 2006/11/20 17:28:10 drizzt Exp $
+
+S="${WORKDIR}"
+
+DESCRIPTION="McAfee VirusScanner for Unix/Linux(Shareware)"
+SRC_URI="http://download.nai.com/products/evaluation/virusscan/english/cmdline/linux/v5.10/vlp${PV}.tar.Z
+ mirror://gentoo/virusscan_updater.sh.gz"
+HOMEPAGE="http://www.mcafeeb2b.com/"
+
+SLOT="0"
+LICENSE="VirusScan"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=" || ( sys-libs/lib-compat
+ app-emulation/emul-linux-x86-compat )
+ amd64? ( app-emulation/emul-linux-x86-baselibs )
+ net-misc/wget"
+DEPEND=""
+
+PROVIDE="virtual/antivirus"
+RESTRICT="binchecks nostrip nomirror"
+
+src_install() {
+ insinto /opt/vlnx
+ doins "${FILESDIR}"/uvscan.cron
+
+ doins messages.dat license.dat
+
+ insopts -m0755
+ doins uvscan liblnxfv.so.4
+ dosym liblnxfv.so.4 /opt/vlnx/liblnxfv.so
+ doins virusscan_updater.sh
+
+ insinto /opt/bin
+ newins "${FILESDIR}"/uvscan.sh uvscan
+
+ dodoc *.{pdf,txt}
+ doman uvscan.1
+
+ insinto /etc
+ doins "${FILESDIR}"/uvscan.conf
+}
+
+pkg_postinst() {
+ ebegin "Downloading DAT files (this may take a few minutes)"
+ /opt/vlnx/virusscan_updater.sh
+ eend $?
+
+ echo
+ einfo "Recommended amavisd-new command line:"
+ einfo " '--secure --mime --program --mailbox -rv --summary --noboot --timeout 180'"
+ echo
+ einfo "If you wish to have your filesystem scanned for malware daily, put file"
+ einfo "/opt/vlnx/uvscan.cron into /etc/cron.daily/"
+ einfo "Note that this script is set to remove infected files silently."
+ echo
+}