summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-08 00:09:29 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-08 00:09:29 +0000
commit23621bf1e8e39e946c767aeea14f3d4815f74bdf (patch)
tree608d23fca9960216017137482301fe2b8185bf5b /app-admin
parentAdded cron user (diff)
downloadhistorical-23621bf1e8e39e946c767aeea14f3d4815f74bdf.tar.gz
historical-23621bf1e8e39e946c767aeea14f3d4815f74bdf.tar.bz2
historical-23621bf1e8e39e946c767aeea14f3d4815f74bdf.zip
Update
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/fcron/fcron-1.1.0.ebuild38
-rw-r--r--app-admin/fcron/files/digest-fcron-1.1.01
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/fcron/fcron-1.1.0.ebuild b/app-admin/fcron/fcron-1.1.0.ebuild
new file mode 100644
index 000000000000..03ec1634b0fb
--- /dev/null
+++ b/app-admin/fcron/fcron-1.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fcron/fcron-1.1.0.ebuild,v 1.1 2001/05/08 00:09:29 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A replacement for vcron"
+SRC_URI="http://fcron.free.fr/${P}.src.tar.gz"
+HOMEPAGE="http://fcron.free.fr/"
+
+DEPEND="virtual/glibc virtual/mta"
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --with-etcdir=/etc/fcron \
+ --with-spooldir=/var/spool/fcron \
+ --with-sendmail=/usr/sbin/sendmail \
+ --with-username=cron \
+ --with-groupname=cron
+ cp Makefile Makefile.orig
+ sed -e "s:\$(SRCDIR)/script/boot-install:#:" Makefile.orig > Makefile
+ try make CFLAGS=\"${CFLAGS}\"
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr \
+ DESTMAN=${D}/usr/share/man \
+ DESTDOC=${D}/usr/share/doc/${PF} \
+ FCRONTABS=${D}/var/spool/fcron \
+ ETC=${D}/etc/fcron install
+ dodoc MANIFEST VERSION doc/CHANGES doc/README doc/LICENSE
+ docinto html
+ dodoc doc/*.html
+ rm -rf ${D}/usr/share/doc/${PF}/${PN}-${PV}
+}
+
diff --git a/app-admin/fcron/files/digest-fcron-1.1.0 b/app-admin/fcron/files/digest-fcron-1.1.0
new file mode 100644
index 000000000000..797d5dc4b35a
--- /dev/null
+++ b/app-admin/fcron/files/digest-fcron-1.1.0
@@ -0,0 +1 @@
+MD5 ad1d380cceaa3b2a072c478f5c9ec2b2 fcron-1.1.0.src.tar.gz