summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-23 15:36:37 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-23 15:36:37 +0000
commit185437cab5eb584ed9d6ca380bda4dd14e090f89 (patch)
treec0c365ea389009edf81163383dbfde50bda853fb /app-admin
parentmasked dev-db/mysqlcc (diff)
downloadhistorical-185437cab5eb584ed9d6ca380bda4dd14e090f89.tar.gz
historical-185437cab5eb584ed9d6ca380bda4dd14e090f89.tar.bz2
historical-185437cab5eb584ed9d6ca380bda4dd14e090f89.zip
uclibc lovin
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/watchdog/Manifest9
-rw-r--r--app-admin/watchdog/files/5.2.4-uclibc.patch11
-rw-r--r--app-admin/watchdog/watchdog-5.2.4.ebuild3
3 files changed, 18 insertions, 5 deletions
diff --git a/app-admin/watchdog/Manifest b/app-admin/watchdog/Manifest
index 070bcf73a89a..2851802c8863 100644
--- a/app-admin/watchdog/Manifest
+++ b/app-admin/watchdog/Manifest
@@ -3,7 +3,7 @@ Hash: SHA1
MD5 c371758f4f4b2031f28c883681bf306a ChangeLog 1158
MD5 22ccd403860117b3e9763f4a2e3027b7 watchdog-5.2.ebuild 1333
-MD5 cb07147330894688ed0311063d8f855d watchdog-5.2.4.ebuild 1309
+MD5 ae9674785349688444c10a45a636641f watchdog-5.2.4.ebuild 1385
MD5 757b9ad893b290e7f0e8281d87970b1e files/watchdog.conf.d 273
MD5 b8a1e49beda941e07c53020b8fb7a1a9 files/digest-watchdog-5.2 64
MD5 96232179b747a1bcacf83442f9217ec4 files/5.2-alpha.patch 329
@@ -11,10 +11,11 @@ MD5 9295e082000d8e9585828e14b9247524 files/watchdog 660
MD5 a9e8cf348af5828fbdc72e8c1a3bb730 files/5.2-sundries.patch 874
MD5 0f333f39bc92c0a210e813ee338da9e7 files/digest-watchdog-5.2.4 71
MD5 ba2c02768a2e772c14e6332dd6b2e65e files/5.2.4-sundries.patch 752
+MD5 e3a3640b31e70f2956ed8ed4bb39f04a files/5.2.4-uclibc.patch 312
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBIkrBHTu7gpaalycRAp5QAJ4qSb6gQM8apCMhggcJdlOVirPEcwCfVLUM
-V+u/hPz6wUqwIv9Q5x58TJ0=
-=U8Es
+iD8DBQFBKg8oHTu7gpaalycRAo5XAJ4hG4gIPtAN241qWzOrO11g/C942QCeLM7Z
+4xZcHUqYeD3zWdxaNcAHxOU=
+=EI9p
-----END PGP SIGNATURE-----
diff --git a/app-admin/watchdog/files/5.2.4-uclibc.patch b/app-admin/watchdog/files/5.2.4-uclibc.patch
new file mode 100644
index 000000000000..1986ed88774a
--- /dev/null
+++ b/app-admin/watchdog/files/5.2.4-uclibc.patch
@@ -0,0 +1,11 @@
+--- src/fstab.c.orig 2004-08-23 15:32:22 +0000
++++ src/fstab.c 2004-08-23 15:32:36 +0000
+@@ -237,7 +237,7 @@
+ /* Ensure that the lock is released if we are interrupted. */
+ static void
+ handler (int sig) {
+- die (EX_USER, "%s", sys_siglist[sig]);
++ die (EX_USER, "%s", strsignal(sig));
+ }
+
+ static void
diff --git a/app-admin/watchdog/watchdog-5.2.4.ebuild b/app-admin/watchdog/watchdog-5.2.4.ebuild
index d1fba3e00a85..4f6a35a97f35 100644
--- a/app-admin/watchdog/watchdog-5.2.4.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.4.ebuild,v 1.2 2004/08/17 18:13:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.4.ebuild,v 1.3 2004/08/23 15:36:37 vapier Exp $
inherit eutils
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-sundries.patch
+ [ "${PORTAGE_LIBC}" == "uclibc" ] && epatch ${FILESDIR}/${PV}-uclibc.patch
}
src_compile() {