summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-11-05 03:01:59 +0000
committerJeroen Roovers <jer@gentoo.org>2012-11-05 03:01:59 +0000
commit54984d46a516faf8d6c9b6c758b62a836609e78e (patch)
tree732342e8628bb15e7d0106c3a4f1004f49d46b63 /app-admin/whowatch/files
parentFix overflow identified by Vicente Olivert Riera in bug #441420; use a patch ... (diff)
downloadhistorical-54984d46a516faf8d6c9b6c758b62a836609e78e.tar.gz
historical-54984d46a516faf8d6c9b6c758b62a836609e78e.tar.bz2
historical-54984d46a516faf8d6c9b6c758b62a836609e78e.zip
Build verbosely. Fix the code that is used when the select() configure test fails (bug #441798 by Stephen Lecheler).
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0xA792A613
Diffstat (limited to 'app-admin/whowatch/files')
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.3-exit.patch17
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.3-verbose.patch20
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/whowatch/files/whowatch-1.8.3-exit.patch b/app-admin/whowatch/files/whowatch-1.8.3-exit.patch
new file mode 100644
index 000000000000..384d42004568
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.3-exit.patch
@@ -0,0 +1,17 @@
+--- a/src/whowatch.c
++++ b/src/whowatch.c
+@@ -436,12 +436,12 @@
+ gettimeofday(&after, 0);
+ tv.tv_sec -= (after.tv_sec - before.tv_sec);
+ if(retval > 0) {
+- int key = read_key();
++ key = getkey();
+ key_action(key);
+ }
+ if(tv.tv_sec <= 0) {
+ ticks++;
+- periodic();
++ main_periodic();
+ tv.tv_sec = TIMEOUT;
+ }
+ #endif
diff --git a/app-admin/whowatch/files/whowatch-1.8.3-verbose.patch b/app-admin/whowatch/files/whowatch-1.8.3-verbose.patch
new file mode 100644
index 000000000000..5b571ed24507
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.3-verbose.patch
@@ -0,0 +1,20 @@
+--- src/Makefile.in.org 2006-03-16 11:53:33.000000000 +0100
++++ src/Makefile.in 2012-11-05 03:45:48.854646487 +0100
+@@ -35,7 +35,7 @@
+
+ top_builddir = .
+
+-CC = @echo " Compiling" [$@] ; @CC@
++CC = @CC@
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
+
+@@ -60,7 +60,7 @@
+ whowatch_LDFLAGS =
+ CFLAGS = @CFLAGS@ -Wall -I. -ggdb
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+-CCLD = @echo " Creating" $@ ; @CC@
++CCLD = @CC@
+ LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+
+ all: whowatch