summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-04-09 18:06:26 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-04-09 18:06:26 +0000
commit73f564d4fb5e6f0df3ba17fad760c726906ec3de (patch)
tree7bfd2874831eede304fa603a5c4bc560f1379205 /app-admin/eselect-mesa/eselect-mesa-0.0.10.ebuild
parentPunt code for SRC_URI, it's handled in the ebuilds because it's not consisten... (diff)
downloadhistorical-73f564d4fb5e6f0df3ba17fad760c726906ec3de.tar.gz
historical-73f564d4fb5e6f0df3ba17fad760c726906ec3de.tar.bz2
historical-73f564d4fb5e6f0df3ba17fad760c726906ec3de.zip
Version bump, fixes bug #362747
Package-Manager: portage-2.2.0_alpha29/cvs/Linux x86_64
Diffstat (limited to 'app-admin/eselect-mesa/eselect-mesa-0.0.10.ebuild')
-rw-r--r--app-admin/eselect-mesa/eselect-mesa-0.0.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/eselect-mesa/eselect-mesa-0.0.10.ebuild b/app-admin/eselect-mesa/eselect-mesa-0.0.10.ebuild
new file mode 100644
index 000000000000..9651645a36cc
--- /dev/null
+++ b/app-admin/eselect-mesa/eselect-mesa-0.0.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-mesa/eselect-mesa-0.0.10.ebuild,v 1.1 2011/04/09 18:06:26 chithanh Exp $
+
+EAPI=3
+
+DESCRIPTION="Utility to change the Mesa OpenGL driver being used"
+HOMEPAGE="http://www.gentoo.org/"
+
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.2.4"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins mesa.eselect || die
+}
+
+pkg_postinst() {
+ if has_version ">=media-libs/mesa-7.9" && \
+ ! [ -f "${EROOT}"/usr/share/mesa/eselect-mesa.conf ]; then
+ eerror "Rebuild media-libs/mesa for ${PN} to work."
+ fi
+}