summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-08-02 16:55:15 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-08-02 16:55:15 +0000
commitd1383574d567bba01e78908da420342227361aea (patch)
tree97440ceb1611679d3a15a3cc1b60a539895c7123 /app-admin/equo
parentDowngrade back to version 1995 which does not show compilation issues. New ve... (diff)
downloadhistorical-d1383574d567bba01e78908da420342227361aea.tar.gz
historical-d1383574d567bba01e78908da420342227361aea.tar.bz2
historical-d1383574d567bba01e78908da420342227361aea.zip
version bump
Package-Manager: portage-2.2.0_alpha37/cvs/Linux x86_64
Diffstat (limited to 'app-admin/equo')
-rw-r--r--app-admin/equo/ChangeLog7
-rw-r--r--app-admin/equo/equo-1.0_rc29.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index 4097bb16a458..9e061ddf9978 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.2 2011/07/19 12:38:04 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.3 2011/08/02 16:54:55 lxnay Exp $
+
+*equo-1.0_rc29 (02 Aug 2011)
+
+ 02 Aug 2011; Fabio Erculiani <lxnay@gentoo.org> +equo-1.0_rc29.ebuild:
+ version bump
19 Jul 2011; Fabio Erculiani <lxnay@gentoo.org> equo-1.0_rc27.ebuild:
update DESCRIPTION
diff --git a/app-admin/equo/equo-1.0_rc29.ebuild b/app-admin/equo/equo-1.0_rc29.ebuild
new file mode 100644
index 000000000000..d31445acbd03
--- /dev/null
+++ b/app-admin/equo/equo-1.0_rc29.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc29.ebuild,v 1.1 2011/08/02 16:54:55 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils multilib python bash-completion
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/$(get_libdir)" equo-install || die "make install failed"
+ dobashcompletion "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/entropy/client"
+ bash-completion_pkg_postinst
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/entropy-client-services"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/entropy/client"
+}