summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-09 17:47:42 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-09 17:47:42 +0000
commitfe69d687ea4d57195a84881fff1d82dece655c5b (patch)
treee4d39b25bfb857caf44cfeb8b3b8209e4e300775
parentalpha/ia64/sh/sparc stable wrt #422517 (diff)
downloadhistorical-fe69d687ea4d57195a84881fff1d82dece655c5b.tar.gz
historical-fe69d687ea4d57195a84881fff1d82dece655c5b.tar.bz2
historical-fe69d687ea4d57195a84881fff1d82dece655c5b.zip
Cleanup.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
-rw-r--r--dev-ruby/parsetree/ChangeLog6
-rw-r--r--dev-ruby/parsetree/parsetree-3.0.8.ebuild87
-rw-r--r--dev-ruby/parsetree/parsetree-3.0.9.ebuild87
-rw-r--r--dev-ruby/patron/ChangeLog6
-rw-r--r--dev-ruby/patron/patron-0.4.15.ebuild36
-rw-r--r--dev-ruby/patron/patron-0.4.16.ebuild36
-rw-r--r--dev-ruby/pdf-reader/ChangeLog6
-rw-r--r--dev-ruby/pdf-reader/pdf-reader-0.10.0.ebuild51
-rw-r--r--dev-ruby/pdf-reader/pdf-reader-0.10.1.ebuild51
-rw-r--r--dev-ruby/pdf-reader/pdf-reader-1.1.0.ebuild51
10 files changed, 15 insertions, 402 deletions
diff --git a/dev-ruby/parsetree/ChangeLog b/dev-ruby/parsetree/ChangeLog
index 9fda9b9d31b1..e346339d3387 100644
--- a/dev-ruby/parsetree/ChangeLog
+++ b/dev-ruby/parsetree/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/parsetree
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/ChangeLog,v 1.51 2012/08/19 09:05:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/ChangeLog,v 1.52 2012/09/09 17:43:03 graaff Exp $
+
+ 09 Sep 2012; Hans de Graaff <graaff@gentoo.org> -parsetree-3.0.8.ebuild,
+ -parsetree-3.0.9.ebuild:
+ Cleanup.
*parsetree-3.0.9-r1 (19 Aug 2012)
diff --git a/dev-ruby/parsetree/parsetree-3.0.8.ebuild b/dev-ruby/parsetree/parsetree-3.0.8.ebuild
deleted file mode 100644
index 0644672c1c5c..000000000000
--- a/dev-ruby/parsetree/parsetree-3.0.8.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/parsetree-3.0.8.ebuild,v 1.4 2012/08/16 03:59:53 flameeyes Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_NAME="ParseTree"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="ParseTree extracts the parse tree for a Class or method and returns it as a s-expression."
-HOMEPAGE="http://www.zenspider.com/ZSS/Products/ParseTree/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend '
- >=dev-ruby/RubyInline-3.10.0
- >=dev-ruby/sexp_processor-3.0.0'
-ruby_add_bdepend "
- test? (
- dev-ruby/hoe
- dev-ruby/hoe-seattlerb
- dev-ruby/minitest
- dev-ruby/ruby2ruby
- )
- doc? (
- dev-ruby/hoe
- dev-ruby/hoe-seattlerb
- )"
-
-all_ruby_prepare() {
- # Fix USE=doc by removing the path that triggers running the tests
- # and thus building the extensions in the wrong way.
- sed -i -e '/require_paths/d' Rakefile || die
-
-}
-
-each_ruby_prepare() {
- # RubyInline employs a very stupid caching strategy solely based on
- # the public signatures of methods. Never mind bugs within the C
- # code... We add a dynamic method name to the parsetree interface
- # just so that we can guarantee compilation. Fixes #329497.
- epatch "${FILESDIR}/${PN}-3.0.6-timestamp.patch"
- sed -i -e "s/TIMESTAMP/$(date +%s)/" lib/parse_tree.rb || die
-}
-
-src_compile() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_compile
-}
-
-each_ruby_compile() {
- # The ruby extension uses RubyInline to use C code within Ruby;
- # since it causes us no little pain, we'll do our best here to
- # prebuild the extensions.
-
- INLINEDIR="${PWD}" ${RUBY} -Ilib -rparse_tree -e '' || die "Unable to load ${PN}"
-
- mkdir lib/inline
- cp .ruby_inline/*/*$(get_modname) lib/inline/ || die
-}
-
-src_test() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_test
-}
-
-pkg_postinst() {
- elog "${CATEGORY}/${PN} uses the RubyInline library to build its parser."
- elog "RubyInline builds loadable extensions at runtime in your home"
- elog "directory if they are not supplied by the gems."
- elog ""
- elog "We are currently providing you with pre-built extensions for"
- elog "the Ruby implementations you're using. Unfortunately these are"
- elog "different from version to version, so you might have to"
- elog "rebuild ${CATEGORY}/${PN} after each update to dev-lang/ruby or"
- elog "dev-lang/ruby-enterprise."
-}
diff --git a/dev-ruby/parsetree/parsetree-3.0.9.ebuild b/dev-ruby/parsetree/parsetree-3.0.9.ebuild
deleted file mode 100644
index 8df3db36665f..000000000000
--- a/dev-ruby/parsetree/parsetree-3.0.9.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/parsetree-3.0.9.ebuild,v 1.2 2012/08/16 03:59:53 flameeyes Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_NAME="ParseTree"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="ParseTree extracts the parse tree for a Class or method and returns it as a s-expression."
-HOMEPAGE="http://www.zenspider.com/ZSS/Products/ParseTree/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend '
- >=dev-ruby/RubyInline-3.10.0
- >=dev-ruby/sexp_processor-3.0.0'
-ruby_add_bdepend "
- test? (
- dev-ruby/hoe
- dev-ruby/hoe-seattlerb
- dev-ruby/minitest
- dev-ruby/ruby2ruby
- )
- doc? (
- dev-ruby/hoe
- dev-ruby/hoe-seattlerb
- )"
-
-all_ruby_prepare() {
- # Fix USE=doc by removing the path that triggers running the tests
- # and thus building the extensions in the wrong way.
- sed -i -e '/require_paths/d' Rakefile || die
-
-}
-
-each_ruby_prepare() {
- # RubyInline employs a very stupid caching strategy solely based on
- # the public signatures of methods. Never mind bugs within the C
- # code... We add a dynamic method name to the parsetree interface
- # just so that we can guarantee compilation. Fixes #329497.
- epatch "${FILESDIR}/${PN}-3.0.6-timestamp.patch"
- sed -i -e "s/TIMESTAMP/$(date +%s)/" lib/parse_tree.rb || die
-}
-
-src_compile() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_compile
-}
-
-each_ruby_compile() {
- # The ruby extension uses RubyInline to use C code within Ruby;
- # since it causes us no little pain, we'll do our best here to
- # prebuild the extensions.
-
- INLINEDIR="${PWD}" ${RUBY} -Ilib -rparse_tree -e '' || die "Unable to load ${PN}"
-
- mkdir lib/inline
- cp .ruby_inline/*/*$(get_modname) lib/inline/ || die
-}
-
-src_test() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_test
-}
-
-pkg_postinst() {
- elog "${CATEGORY}/${PN} uses the RubyInline library to build its parser."
- elog "RubyInline builds loadable extensions at runtime in your home"
- elog "directory if they are not supplied by the gems."
- elog ""
- elog "We are currently providing you with pre-built extensions for"
- elog "the Ruby implementations you're using. Unfortunately these are"
- elog "different from version to version, so you might have to"
- elog "rebuild ${CATEGORY}/${PN} after each update to dev-lang/ruby or"
- elog "dev-lang/ruby-enterprise."
-}
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
index 1206214768a5..9ba15fe45c40 100644
--- a/dev-ruby/patron/ChangeLog
+++ b/dev-ruby/patron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/patron
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.22 2012/05/18 06:54:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.23 2012/09/09 17:46:29 graaff Exp $
+
+ 09 Sep 2012; Hans de Graaff <graaff@gentoo.org> -patron-0.4.15.ebuild,
+ -patron-0.4.16.ebuild:
+ Cleanup.
*patron-0.4.18 (18 May 2012)
diff --git a/dev-ruby/patron/patron-0.4.15.ebuild b/dev-ruby/patron/patron-0.4.15.ebuild
deleted file mode 100644
index 7be99b3b6792..000000000000
--- a/dev-ruby/patron/patron-0.4.15.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.15.ebuild,v 1.1 2011/08/26 06:42:31 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_EXTRADOC="README.txt"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
-HOMEPAGE="http://toland.github.com/patron/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
-
-DEPEND="${DEPEND} net-misc/curl"
-RDEPEND="${RDEPEND} net-misc/curl"
-
-# Tests require a live web service that is not included in the distribution.
-RESTRICT="test"
-
-each_ruby_configure() {
- ${RUBY} -Cext/patron extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -Cext/patron || die
- cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
-}
diff --git a/dev-ruby/patron/patron-0.4.16.ebuild b/dev-ruby/patron/patron-0.4.16.ebuild
deleted file mode 100644
index 02f876160112..000000000000
--- a/dev-ruby/patron/patron-0.4.16.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.16.ebuild,v 1.2 2011/11/02 06:22:18 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_EXTRADOC="README.txt"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
-HOMEPAGE="http://toland.github.com/patron/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
-
-DEPEND="${DEPEND} net-misc/curl"
-RDEPEND="${RDEPEND} net-misc/curl"
-
-# Tests require a live web service that is not included in the distribution.
-RESTRICT="test"
-
-each_ruby_configure() {
- ${RUBY} -Cext/patron extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -Cext/patron || die
- cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
-}
diff --git a/dev-ruby/pdf-reader/ChangeLog b/dev-ruby/pdf-reader/ChangeLog
index fa682c472ea9..9c63ad6904a8 100644
--- a/dev-ruby/pdf-reader/ChangeLog
+++ b/dev-ruby/pdf-reader/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/pdf-reader
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-reader/ChangeLog,v 1.29 2012/05/19 06:02:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-reader/ChangeLog,v 1.30 2012/09/09 17:47:42 graaff Exp $
+
+ 09 Sep 2012; Hans de Graaff <graaff@gentoo.org> -pdf-reader-0.10.0.ebuild,
+ -pdf-reader-0.10.1.ebuild, -pdf-reader-1.1.0.ebuild:
+ Cleanup.
*pdf-reader-1.1.1 (19 May 2012)
diff --git a/dev-ruby/pdf-reader/pdf-reader-0.10.0.ebuild b/dev-ruby/pdf-reader/pdf-reader-0.10.0.ebuild
deleted file mode 100644
index 8cbd57dba2fa..000000000000
--- a/dev-ruby/pdf-reader/pdf-reader-0.10.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-reader/pdf-reader-0.10.0.ebuild,v 1.3 2012/03/11 13:45:44 ranger Exp $
-
-EAPI=2
-
-GITHUB_USER=yob
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc TODO"
-
-inherit ruby-fakegem
-
-DESCRIPTION="PDF parser conforming as much as possible to the PDF specification from Adobe"
-HOMEPAGE="http://github.com/yob/pdf-reader/"
-
-# We cannot use the gem distributions because they don't contain the
-# tests' data, we have to rely on the git tags.
-SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/${GITHUB_USER}-${PN}-*"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64"
-IUSE=""
-
-ruby_add_rdepend dev-ruby/ascii85
-
-# rspec is loaded even during doc generation, so keep it around :(
-ruby_add_bdepend ">=dev-ruby/rspec-2.1:2"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die
- rm Gemfile || die
-
- # Roodi is not yet available in CVS.
- sed -i -e '/roodi/d' Rakefile || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/* || die
-}
diff --git a/dev-ruby/pdf-reader/pdf-reader-0.10.1.ebuild b/dev-ruby/pdf-reader/pdf-reader-0.10.1.ebuild
deleted file mode 100644
index 7b9d3d8143a7..000000000000
--- a/dev-ruby/pdf-reader/pdf-reader-0.10.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-reader/pdf-reader-0.10.1.ebuild,v 1.6 2012/05/01 18:24:04 armin76 Exp $
-
-EAPI=4
-
-GITHUB_USER=yob
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc TODO"
-
-inherit ruby-fakegem
-
-DESCRIPTION="PDF parser conforming as much as possible to the PDF specification from Adobe"
-HOMEPAGE="http://github.com/yob/pdf-reader/"
-
-# We cannot use the gem distributions because they don't contain the
-# tests' data, we have to rely on the git tags.
-SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-RUBY_S="${GITHUB_USER}-${PN}-*"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/ascii85"
-
-# rspec is loaded even during doc generation, so keep it around :(
-ruby_add_bdepend ">=dev-ruby/rspec-2.1:2"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die
- rm Gemfile || die
-
- # Roodi is not yet available in CVS.
- sed -i -e '/roodi/d' Rakefile || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/* || die
-}
diff --git a/dev-ruby/pdf-reader/pdf-reader-1.1.0.ebuild b/dev-ruby/pdf-reader/pdf-reader-1.1.0.ebuild
deleted file mode 100644
index 4dee61003e36..000000000000
--- a/dev-ruby/pdf-reader/pdf-reader-1.1.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-reader/pdf-reader-1.1.0.ebuild,v 1.4 2012/05/17 10:54:29 tomka Exp $
-
-EAPI=4
-
-GITHUB_USER=yob
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc TODO"
-
-inherit ruby-fakegem
-
-DESCRIPTION="PDF parser conforming as much as possible to the PDF specification from Adobe"
-HOMEPAGE="http://github.com/yob/pdf-reader/"
-
-# We cannot use the gem distributions because they don't contain the
-# tests' data, we have to rely on the git tags.
-SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-RUBY_S="${GITHUB_USER}-${PN}-*"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/ascii85 dev-ruby/ruby-rc4"
-
-# rspec is loaded even during doc generation, so keep it around :(
-ruby_add_bdepend ">=dev-ruby/rspec-2.1:2"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die
- rm Gemfile || die
-
- # Roodi is not yet available in CVS.
- sed -i -e '/roodi/d' Rakefile || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/* || die
-}