summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 00:03:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 00:03:15 +0000
commitf948ae52db8c4ad40dfffb2e7527f9654b7bee92 (patch)
treeeaaed423f274ca2108a9bbb72963be01ec7b114b
parentDelete older ebuild. (diff)
downloadhistorical-f948ae52db8c4ad40dfffb2e7527f9654b7bee92.tar.gz
historical-f948ae52db8c4ad40dfffb2e7527f9654b7bee92.tar.bz2
historical-f948ae52db8c4ad40dfffb2e7527f9654b7bee92.zip
Use PYTHON_DEPEND instead of NEED_PYTHON.
Package-Manager: portage-HEAD/cvs/Linux x86_64
-rw-r--r--dev-python/dbutils/ChangeLog8
-rw-r--r--dev-python/dbutils/dbutils-1.0.ebuild13
-rw-r--r--dev-python/fusil/ChangeLog6
-rw-r--r--dev-python/fusil/fusil-1.3.2.ebuild8
4 files changed, 21 insertions, 14 deletions
diff --git a/dev-python/dbutils/ChangeLog b/dev-python/dbutils/ChangeLog
index 09469f0900a2..46840468598c 100644
--- a/dev-python/dbutils/ChangeLog
+++ b/dev-python/dbutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dbutils
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbutils/ChangeLog,v 1.3 2009/09/08 20:03:53 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbutils/ChangeLog,v 1.4 2010/06/30 00:00:41 arfrever Exp $
+
+ 30 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ dbutils-1.0.ebuild:
+ Use PYTHON_DEPEND instead of NEED_PYTHON.
08 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
dbutils-1.0.ebuild:
diff --git a/dev-python/dbutils/dbutils-1.0.ebuild b/dev-python/dbutils/dbutils-1.0.ebuild
index 21a50efbd2f0..97f2479e4d28 100644
--- a/dev-python/dbutils/dbutils-1.0.ebuild
+++ b/dev-python/dbutils/dbutils-1.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbutils/dbutils-1.0.ebuild,v 1.2 2009/09/08 20:03:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbutils/dbutils-1.0.ebuild,v 1.3 2010/06/30 00:00:41 arfrever Exp $
-EAPI="2"
-
-NEED_PYTHON="2.4"
+EAPI="3"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
@@ -13,7 +13,7 @@ MY_PN="DBUtils"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Database connections for multi-threaded environments."
-HOMEPAGE="http://www.webwareforpython.org/DBUtils"
+HOMEPAGE="http://www.webwareforpython.org/DBUtils http://pypi.python.org/pypi/DBUtils"
SRC_URI="http://www.webwareforpython.org/downloads/DBUtils/${MY_P}.tar.gz"
LICENSE="OSL-2.0"
@@ -23,7 +23,6 @@ IUSE=""
DEPEND=""
RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/fusil/ChangeLog b/dev-python/fusil/ChangeLog
index 31a8fc393ad1..a8185989e13b 100644
--- a/dev-python/fusil/ChangeLog
+++ b/dev-python/fusil/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/fusil
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.5 2010/01/09 19:59:57 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.6 2010/06/30 00:03:15 arfrever Exp $
+
+ 30 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ fusil-1.3.2.ebuild:
+ Use PYTHON_DEPEND instead of NEED_PYTHON.
*fusil-1.3.2 (09 Jan 2010)
diff --git a/dev-python/fusil/fusil-1.3.2.ebuild b/dev-python/fusil/fusil-1.3.2.ebuild
index 1e2abf1db0e1..3933d0f4b10e 100644
--- a/dev-python/fusil/fusil-1.3.2.ebuild
+++ b/dev-python/fusil/fusil-1.3.2.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.3.2.ebuild,v 1.3 2010/02/28 13:39:51 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.3.2.ebuild,v 1.4 2010/06/30 00:03:15 arfrever Exp $
-EAPI="2"
-NEED_PYTHON="2.5"
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
inherit distutils eutils
@@ -19,7 +20,6 @@ IUSE="doc examples"
DEPEND=">=dev-python/python-ptrace-0.6"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="2.4"
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"