summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-29 05:39:24 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-29 05:39:24 +0000
commitd80c031059afa52bb8a7aef09d068328e7edfe0f (patch)
tree7d805281ba5d4e98a416cace465cfeeca57b85db
parentVersion 2.5.6 is out. (diff)
downloadhistorical-d80c031059afa52bb8a7aef09d068328e7edfe0f.tar.gz
historical-d80c031059afa52bb8a7aef09d068328e7edfe0f.tar.bz2
historical-d80c031059afa52bb8a7aef09d068328e7edfe0f.zip
updated ebuild which fixes build problems
-rw-r--r--media-sound/lame/ChangeLog9
-rw-r--r--media-sound/lame/files/digest-lame-3.93.1-r11
-rw-r--r--media-sound/lame/lame-3.93.1-r1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index dce5bfb70e58..ce1fadcf788b 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/lame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.16 2003/01/01 00:47:24 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.17 2003/01/29 05:39:24 raker Exp $
+
+*lame-3.93.1-r1 (28 Jan 2003)
+
+ 28 Jan 2003; Nick Hadaway <raker@gentoo.org> lame-3.93.1-r1.ebuild,
+ files/digest-lame-3.93.1-r1 :
+ Got rid of the autotools and libtool workarounds and just sed'd the
+ configure script gtk detection.
16 Dec 2002; Martin Schlemmer <azarah@gentoo.org> lame-3.93.1.ebuild :
Run autoreconf to fix the ./configure script not detecting gtk-config
diff --git a/media-sound/lame/files/digest-lame-3.93.1-r1 b/media-sound/lame/files/digest-lame-3.93.1-r1
new file mode 100644
index 000000000000..bc8392a0b0e7
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.93.1-r1
@@ -0,0 +1 @@
+MD5 1b79c08045eafc55e24ebd38d9e84329 lame-3.93.1.tar.gz 1037603
diff --git a/media-sound/lame/lame-3.93.1-r1.ebuild b/media-sound/lame/lame-3.93.1-r1.ebuild
new file mode 100644
index 000000000000..c7fbe5b184e7
--- /dev/null
+++ b/media-sound/lame/lame-3.93.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.93.1-r1.ebuild,v 1.1 2003/01/29 05:39:24 raker Exp $
+
+IUSE="gtk"
+DESCRIPTION="LAME Ain't an Mp3 Encoder"
+SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
+HOMEPAGE="http://www.mp3dev.org/mp3/"
+DEPEND="virtual/glibc
+ x86? ( dev-lang/nasm )
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+# this release completely removed oggvorbis support as it was too outdated.
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc alpha"
+
+src_compile() {
+ # fix gtk detection
+ cp configure configure.orig
+ sed -e "s:gtk12-config:gtk-config:" < configure.orig > configure
+
+ local myconf=""
+ if [ "`use gtk`" ] ; then
+ myconf="${myconf} --enable-mp3x"
+ fi
+ if [ "${DEBUG}" ] ; then
+ myconf="${myconf} --enable-debug=yes"
+ else
+ myconf="${myconf} --enable-debug=no"
+ fi
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-shared \
+ --enable-nasm \
+ --enable-mp3rtp \
+ --enable-extopt=full \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ pkghtmldir=${D}/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc API COPYING HACKING PRESETS.draft LICENSE README* TODO USAGE
+ dohtml -r ./
+}
+