summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 03:09:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 03:09:49 +0000
commitceb93dca1e32ccab9c3d2e7220425f70d27796b2 (patch)
tree4010d72c027584520c74a579d2cd18e3cdb5c2c8
parentold (diff)
downloadhistorical-ceb93dca1e32ccab9c3d2e7220425f70d27796b2.tar.gz
historical-ceb93dca1e32ccab9c3d2e7220425f70d27796b2.tar.bz2
historical-ceb93dca1e32ccab9c3d2e7220425f70d27796b2.zip
change CFLAGS=-O2 to strip-flags
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.7-r1.ebuild15
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.7-r2.ebuild15
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.7-r3.ebuild15
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.7-r4.ebuild13
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.7.ebuild17
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild15
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.8.ebuild15
-rw-r--r--sys-devel/binutils/binutils-2.15.90.0.3-r1.ebuild13
8 files changed, 36 insertions, 82 deletions
diff --git a/sys-devel/binutils/binutils-2.14.90.0.7-r1.ebuild b/sys-devel/binutils/binutils-2.14.90.0.7-r1.ebuild
index ce8fba38b0bd..ea0dded28523 100644
--- a/sys-devel/binutils/binutils-2.14.90.0.7-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.14.90.0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7-r1.ebuild,v 1.5 2004/04/24 14:00:06 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7-r1.ebuild,v 1.6 2004/04/25 03:09:49 vapier Exp $
IUSE="nls bootstrap build"
@@ -87,16 +87,9 @@ src_compile() {
myconf="${myconf} --disable-nls"
# Filter CFLAGS=".. -O2 .." on arm
- if [ "${ARCH}" = "arm" ]
- then
- CFLAGS="$(echo "${CFLAGS}" | sed -e 's,-O[2-9] ,-O1 ,')"
- fi
-
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
-
+ use arm && replace-flags -O? -O
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
+ has_version "=sys-devel/gcc-3.4*" && strip-flags
# Fix /usr/lib/libbfd.la
elibtoolize --portage
diff --git a/sys-devel/binutils/binutils-2.14.90.0.7-r2.ebuild b/sys-devel/binutils/binutils-2.14.90.0.7-r2.ebuild
index d162739c5479..048884ca05a4 100644
--- a/sys-devel/binutils/binutils-2.14.90.0.7-r2.ebuild
+++ b/sys-devel/binutils/binutils-2.14.90.0.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7-r2.ebuild,v 1.6 2004/04/24 14:00:06 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7-r2.ebuild,v 1.7 2004/04/25 03:09:49 vapier Exp $
IUSE="nls bootstrap build"
@@ -101,16 +101,9 @@ src_compile() {
myconf="${myconf} --disable-nls"
# Filter CFLAGS=".. -O2 .." on arm
- if [ "${ARCH}" = "arm" ]
- then
- CFLAGS="$(echo "${CFLAGS}" | sed -e 's,-O[2-9] ,-O1 ,')"
- fi
-
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
-
+ use arm && replace-flags -O? -O
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
+ has_version "=sys-devel/gcc-3.4*" && strip-flags
# Fix /usr/lib/libbfd.la
elibtoolize --portage
diff --git a/sys-devel/binutils/binutils-2.14.90.0.7-r3.ebuild b/sys-devel/binutils/binutils-2.14.90.0.7-r3.ebuild
index 3f232913eaa8..6e7a16fc2e0f 100644
--- a/sys-devel/binutils/binutils-2.14.90.0.7-r3.ebuild
+++ b/sys-devel/binutils/binutils-2.14.90.0.7-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7-r3.ebuild,v 1.11 2004/04/24 14:00:06 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7-r3.ebuild,v 1.12 2004/04/25 03:09:49 vapier Exp $
IUSE="nls bootstrap build"
@@ -102,16 +102,9 @@ src_compile() {
myconf="${myconf} --disable-nls"
# Filter CFLAGS=".. -O2 .." on arm
- if [ "${ARCH}" = "arm" ]
- then
- CFLAGS="$(echo "${CFLAGS}" | sed -e 's,-O[2-9] ,-O1 ,')"
- fi
-
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
-
+ use arm && replace-flags -O? -O
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
+ has_version "=sys-devel/gcc-3.4*" && strip-flags
# Fix /usr/lib/libbfd.la
elibtoolize --portage
diff --git a/sys-devel/binutils/binutils-2.14.90.0.7-r4.ebuild b/sys-devel/binutils/binutils-2.14.90.0.7-r4.ebuild
index fb9d2e37f443..69d30c44735d 100644
--- a/sys-devel/binutils/binutils-2.14.90.0.7-r4.ebuild
+++ b/sys-devel/binutils/binutils-2.14.90.0.7-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7-r4.ebuild,v 1.5 2004/04/24 14:00:06 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7-r4.ebuild,v 1.6 2004/04/25 03:09:49 vapier Exp $
# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
# the manpages, but seems this is incorrect ....
@@ -94,13 +94,10 @@ src_compile() {
# Generate borked binaries. Bug #6730
filter-flags -fomit-frame-pointer -fssa
- use arm && filter-flags -O2 -O3
-
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
-
+ # Filter CFLAGS=".. -O2 .." on arm
+ use arm && replace-flags -O? -O
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
+ has_version "=sys-devel/gcc-3.4*" && strip-flags
# Fix /usr/lib/libbfd.la
elibtoolize --portage
diff --git a/sys-devel/binutils/binutils-2.14.90.0.7.ebuild b/sys-devel/binutils/binutils-2.14.90.0.7.ebuild
index b5d30999bc35..ca2a81208d8e 100644
--- a/sys-devel/binutils/binutils-2.14.90.0.7.ebuild
+++ b/sys-devel/binutils/binutils-2.14.90.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7.ebuild,v 1.8 2004/04/24 14:00:06 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.7.ebuild,v 1.9 2004/04/25 03:09:49 vapier Exp $
IUSE="nls bootstrap build"
@@ -82,17 +82,12 @@ src_compile() {
myconf="${myconf} --without-included-gettext" || \
myconf="${myconf} --disable-nls"
+ # Generate borked binaries. Bug #6730
+ filter-flags -fomit-frame-pointer -fssa
# Filter CFLAGS=".. -O2 .." on arm
- if [ "${ARCH}" = "arm" ]
- then
- CFLAGS="$(echo "${CFLAGS}" | sed -e 's,-O[2-9] ,-O1 ,')"
- fi
-
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
-
+ use arm && replace-flags -O? -O
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
+ has_version "=sys-devel/gcc-3.4*" && strip-flags
# Fix /usr/lib/libbfd.la
elibtoolize --portage
diff --git a/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild b/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
index 5e398b6e9bfe..f892333e637c 100644
--- a/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild,v 1.8 2004/04/24 14:00:06 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild,v 1.9 2004/04/25 03:09:49 vapier Exp $
IUSE="nls bootstrap build"
@@ -63,16 +63,9 @@ src_compile() {
myconf="${myconf} --disable-nls"
# Filter CFLAGS=".. -O2 .." on arm
- if [ "${ARCH}" = "arm" ]
- then
- CFLAGS="$(echo "${CFLAGS}" | sed -e 's,-O[2-9] ,-O1 ,')"
- fi
-
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
-
+ use arm && replace-flags -O? -O
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
+ has_version "=sys-devel/gcc-3.4*" && strip-flags
# Fix /usr/lib/libbfd.la
elibtoolize --portage
diff --git a/sys-devel/binutils/binutils-2.14.90.0.8.ebuild b/sys-devel/binutils/binutils-2.14.90.0.8.ebuild
index e50c50227f0f..73a57606349d 100644
--- a/sys-devel/binutils/binutils-2.14.90.0.8.ebuild
+++ b/sys-devel/binutils/binutils-2.14.90.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.8.ebuild,v 1.4 2004/04/24 14:00:06 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.8.ebuild,v 1.5 2004/04/25 03:09:49 vapier Exp $
IUSE="nls bootstrap build"
@@ -65,16 +65,9 @@ src_compile() {
myconf="${myconf} --disable-nls"
# Filter CFLAGS=".. -O2 .." on arm
- if [ "${ARCH}" = "arm" ]
- then
- CFLAGS="$(echo "${CFLAGS}" | sed -e 's,-O[2-9] ,-O1 ,')"
- fi
-
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
-
+ use arm && replace-flags -O? -O
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
+ has_version "=sys-devel/gcc-3.4*" && strip-flags
# Fix /usr/lib/libbfd.la
elibtoolize --portage
diff --git a/sys-devel/binutils/binutils-2.15.90.0.3-r1.ebuild b/sys-devel/binutils/binutils-2.15.90.0.3-r1.ebuild
index 4874814a0102..fa8cb9bd6b00 100644
--- a/sys-devel/binutils/binutils-2.15.90.0.3-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.15.90.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.90.0.3-r1.ebuild,v 1.3 2004/04/24 14:00:06 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.90.0.3-r1.ebuild,v 1.4 2004/04/25 03:09:49 vapier Exp $
# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
# the manpages, but seems this is incorrect ....
@@ -60,6 +60,8 @@ src_compile() {
filter-flags -fomit-frame-pointer -fssa
# Filter CFLAGS=".. -O2 .." on arm
use arm && replace-flags -O? -O
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
+ has_version "=sys-devel/gcc-3.4*" && strip-flags
local myconf=
[ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
@@ -70,12 +72,6 @@ src_compile() {
# untested functionality.
# use cross && myconf="${myconf} --targets-all"
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
-
-
# Fix /usr/lib/libbfd.la
elibtoolize --portage
@@ -106,7 +102,8 @@ src_compile() {
}
src_install() {
- make prefix=${D}/usr \
+ make \
+ prefix=${D}/usr \
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
install || die