summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-03-18 09:43:20 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-03-18 09:43:20 +0000
commitb3de9f7856739d60387c3eeb1313a63d538bdaaf (patch)
tree9e670483faea7f57ea67dc4b274286edc3850ff3
parentSimplify the inst_plugin and enable it to change the symlink destination if n... (diff)
downloadhistorical-b3de9f7856739d60387c3eeb1313a63d538bdaaf.tar.gz
historical-b3de9f7856739d60387c3eeb1313a63d538bdaaf.tar.bz2
historical-b3de9f7856739d60387c3eeb1313a63d538bdaaf.zip
Fix plugin-installation thanks to Kevin Andre Vatn. <kevinava@stud.aitel.hist.no>, fix typos thanks to SwifT, thanks to appro for testing.
Package-Manager: portage-1.585-cvs
-rw-r--r--app-text/acroread/ChangeLog7
-rw-r--r--app-text/acroread/Manifest14
-rw-r--r--app-text/acroread/acroread-7.0.ebuild22
3 files changed, 17 insertions, 26 deletions
diff --git a/app-text/acroread/ChangeLog b/app-text/acroread/ChangeLog
index ccfc113b0103..f8b1f339e1e5 100644
--- a/app-text/acroread/ChangeLog
+++ b/app-text/acroread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/acroread
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.47 2005/03/16 20:03:28 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.48 2005/03/18 09:43:20 genstef Exp $
+
+ 18 Mar 2005; Stefan Schweizer <genstef@gentoo.org> acroread-7.0.ebuild:
+ Fix plugin-installation thanks to Kevin Andre Vatn.
+ <kevinava@stud.aitel.hist.no>, fix typos thanks to SwifT, thanks to appro
+ for testing.
16 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> acroread-5.10.ebuild:
stable on amd64, fixes #85101
diff --git a/app-text/acroread/Manifest b/app-text/acroread/Manifest
index 61f1f37ebae1..3f5f0c72bb9a 100644
--- a/app-text/acroread/Manifest
+++ b/app-text/acroread/Manifest
@@ -1,16 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 431799662d49f85bbe6bfaba14090763 acroread-7.0.ebuild 2511
+MD5 631a8ea5acd60b2ebdb650cfc77a9a3b acroread-7.0.ebuild 2309
MD5 c6d652ceac26d8852481efc293bff3bd acroread-5.10.ebuild 2364
-MD5 2fd1985e789c2d9beb77ba66cf2b53f0 ChangeLog 8039
+MD5 e7abb6e4aa6b68af70e9b52d94267477 ChangeLog 8257
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 d0981fc5a58874b78a6f2a2b73d3e43d files/digest-acroread-5.10 63
MD5 c54a04836864a99a8792ef5817a968c1 files/digest-acroread-7.0 73
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCOJEW06ebR+OMO78RApFPAKCW+IJOMYuTiZSVVQtpp5/+y/nosACeNS1+
-NUILa4gBU/kq1Wkl6sz1OuY=
-=zU7I
------END PGP SIGNATURE-----
diff --git a/app-text/acroread/acroread-7.0.ebuild b/app-text/acroread/acroread-7.0.ebuild
index cc9191956cdf..1d69f4e3dedb 100644
--- a/app-text/acroread/acroread-7.0.ebuild
+++ b/app-text/acroread/acroread-7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-7.0.ebuild,v 1.4 2005/03/15 20:00:17 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-7.0.ebuild,v 1.5 2005/03/18 09:43:20 genstef Exp $
inherit nsplugins eutils
@@ -39,7 +39,6 @@ src_install() {
dodir ${INSTALLDIR}
DIRS="Reader Resource"
- use !noplugin && DIRS="${DIRS} Browser"
for i in ${DIRS}
do
if [ -d ${i} ] ; then
@@ -50,12 +49,12 @@ src_install() {
exeinto ${INSTALLDIR}
doexe bin/acroread || die "doexe failed"
- dodoc README LICREAD.TXT
+ dodoc README LICREAD.TXT Browser/Browser_Plugin_HowTo.txt
if ! use noplugin ; then
- dodir /opt/netscape/plugins
- dosym ${INSTALLDIR}/Browser/intellinux/nppdf.so /opt/netscape/plugins
- inst_plugin ${INSTALLDIR}/Browser/intellinux/nppdf.so
+ exeinto /opt/netscape/plugins
+ doexe Browser/intellinux/nppdf.so
+ inst_plugin /opt/netscape/plugins/nppdf.so
fi
if use amd64 ; then
@@ -64,8 +63,7 @@ src_install() {
fi
if use amd64 || ! use ldap ; then
- mv ${D}${INSTALLDIR}/Reader/intellinux/plug_ins/PPKLite.api \
- ${D}${INSTALLDIR}/Reader/intellinux/plug_ins/PPKLite.api.disabled
+ rm ${D}${INSTALLDIR}/Reader/intellinux/plug_ins/PPKLite.api
fi
dodir /usr/bin
@@ -76,13 +74,11 @@ pkg_postinst () {
# fix wrong directory permissions (bug #25931)
find ${INSTALLDIR} -type d | xargs chmod 755 || die
- einfo "The browser plugin does not work on firefox 1.0.1 (yet)"
- einfo
- einfo "Asianfonts are not avaiable seperately for version 7 (yet)"
- einfo "The work around for the time being is to copy the 'Resource' directory from"
+ einfo "Asianfonts are not available separately for version 7 (yet)"
+ einfo "The workaround for the time being is to copy the 'Resource' directory from"
einfo "a windows machine with acrobat reader 7 and asian font support installed."
einfo
einfo "The Acrobat(TM) Security Plugin will be enabled with USE=ldap, it"
- einfo "does not work with amd64 because there there is no x86 ldap-emulation"
+ einfo "does not work with amd64 because there is no x86 ldap-emulation"
einfo "package available in portage."
}