summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-03-18 18:05:02 +0000
committerMarinus Schraal <foser@gentoo.org>2004-03-18 18:05:02 +0000
commit96852624a4a11c98e1ed3e4080ee743ed151ec0a (patch)
tree80f544183ee4d5aa13d47e2cdf58af4d8d08cfc5
parentreadded mips keyword (diff)
downloadhistorical-96852624a4a11c98e1ed3e4080ee743ed151ec0a.tar.gz
historical-96852624a4a11c98e1ed3e4080ee743ed151ec0a.tar.bz2
historical-96852624a4a11c98e1ed3e4080ee743ed151ec0a.zip
new release
-rw-r--r--x11-libs/gtk+/ChangeLog10
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.4.01
-rw-r--r--x11-libs/gtk+/gtk+-2.4.0.ebuild98
3 files changed, 108 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 8ddad64892e1..790845d6aeca 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.86 2004/03/07 04:04:55 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.87 2004/03/18 18:05:02 foser Exp $
+*gtk+-2.4.0 (18 Mar 2004)
+
+ 18 Mar 2004; foser <foser@gentoo.org> gtk+-2.4.0.ebuild :
+ New release
+ Remove incorporated patches
+ Removed wm patch, it's broken
+ Correct license
+
06 Mar 2004; Stephen P. Becker <geoman@gentoo.org> gtk+-1.2.10-r10.ebuild,
gtk+-2.2.4-r1.ebuild:
Added ~mips keyword.
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.4.0 b/x11-libs/gtk+/files/digest-gtk+-2.4.0
new file mode 100644
index 000000000000..927736ca506c
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.4.0
@@ -0,0 +1 @@
+MD5 fd16157de447c7f0a86495ad0dc67a1b gtk+-2.4.0.tar.bz2 8476610
diff --git a/x11-libs/gtk+/gtk+-2.4.0.ebuild b/x11-libs/gtk+/gtk+-2.4.0.ebuild
new file mode 100644
index 000000000000..864363b70635
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.4.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.0.ebuild,v 1.1 2004/03/18 18:05:02 foser Exp $
+
+inherit libtool flag-o-matic eutils
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.4/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64 ~hppa ~ia64 ~mips"
+IUSE="doc tiff jpeg"
+
+# virtual/x11
+# Need this specific xfree version to get bugfree xinput support (#20407)
+
+RDEPEND=">=x11-base/xfree-4.3.0-r3
+ >=dev-libs/glib-2.4
+ >=dev-libs/atk-1.0.1
+ >=x11-libs/pango-1.4
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # Turn of --export-symbols-regex for now, since it removes
+ # the wrong symbols
+ epatch ${FILESDIR}/gtk+-2.0.6-exportsymbols.patch
+ # beautifying patch for disabled icons
+ epatch ${FILESDIR}/${PN}-2.2.1-disable_icons_smooth_alpha.patch
+
+ autoconf || die
+
+}
+
+src_compile() {
+
+ # bug 8762
+ replace-flags "-O3" "-O2"
+
+ elibtoolize
+
+ econf \
+ `use_enable doc gtk-doc` \
+ `use_with jpeg libjpeg` \
+ `use_with tiff libtiff` \
+ --with-png \
+ --with-gdktarget=x11 \
+ --with-xinput \
+ || die
+
+ # gtk+ isn't multithread friendly due to some obscure code generation bug
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die
+
+}
+
+src_install() {
+
+ dodir /etc/gtk-2.0
+
+ make DESTDIR=${D} install || die
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ dodir /etc/env.d
+ echo "GDK_USE_XFT=1" >${D}/etc/env.d/50gtk2
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING INSTALL NEWS* README*
+
+}
+
+pkg_postinst() {
+
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+ gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
+
+ einfo "For gtk themes to work correctly after an update, you might have to rebuild your theme engines."
+ einfo "Executing 'qpkg -f -nc /usr/lib/gtk-2.0/2.2.0/engines | xargs emerge' should do the trick if"
+ einfo "you upgrade from gtk+-2.2 to 2.4 (requires gentoolkit)."
+
+ env-update
+
+}
+
+pkg_postrm() {
+
+ env-update
+
+}