summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-09-08 23:50:33 +0000
committerMarinus Schraal <foser@gentoo.org>2003-09-08 23:50:33 +0000
commit938e280fc176def290abda6f830758b1b9ba19c3 (patch)
tree89b740768d3261390e5e8b7f4461494646e8c24e
parentnew release (diff)
downloadhistorical-938e280fc176def290abda6f830758b1b9ba19c3.tar.gz
historical-938e280fc176def290abda6f830758b1b9ba19c3.tar.bz2
historical-938e280fc176def290abda6f830758b1b9ba19c3.zip
new release
-rw-r--r--media-sound/rhythmbox/Manifest4
-rw-r--r--media-sound/rhythmbox/files/digest-rhythmbox-0.5.31
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.5.3.ebuild56
3 files changed, 59 insertions, 2 deletions
diff --git a/media-sound/rhythmbox/Manifest b/media-sound/rhythmbox/Manifest
index c1e3d4bb1cbd..61ebb6604e10 100644
--- a/media-sound/rhythmbox/Manifest
+++ b/media-sound/rhythmbox/Manifest
@@ -1,7 +1,7 @@
MD5 3f91ab5fec8022d8221bcca3c17bd4e3 rhythmbox-0.5.1.ebuild 1470
-MD5 58ac622d89f043f7906496cf2e62325a rhythmbox-0.5.3.ebuild 1153
+MD5 ada3dacc2a0d1ad6fd3b446bc17719b3 rhythmbox-0.5.3.ebuild 1442
MD5 d348c2782328bd866222526442ea9447 rhythmbox-0.5.0.ebuild 1482
-MD5 e54a957396305bf5a42f29f6b8b7ddd7 ChangeLog 727
+MD5 3aa515bedba5d898151f72aeaf31fe72 ChangeLog 972
MD5 ab865b430e07f028d861503a1669dc97 files/digest-rhythmbox-0.5.0 68
MD5 44fc4699d370d1b03eb5d60c273f755f files/digest-rhythmbox-0.5.1 68
MD5 a5cac79c211eb4eebac4e1f056736e65 files/digest-rhythmbox-0.5.3 69
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.5.3 b/media-sound/rhythmbox/files/digest-rhythmbox-0.5.3
new file mode 100644
index 000000000000..4d9a05d1176b
--- /dev/null
+++ b/media-sound/rhythmbox/files/digest-rhythmbox-0.5.3
@@ -0,0 +1 @@
+MD5 a00a4dafbdbfe6ff3b686b3e82c9cdab rhythmbox-0.5.3.tar.bz2 1530309
diff --git a/media-sound/rhythmbox/rhythmbox-0.5.3.ebuild b/media-sound/rhythmbox/rhythmbox-0.5.3.ebuild
new file mode 100644
index 000000000000..e6596098d313
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.5.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.5.3.ebuild,v 1.1 2003/09/08 23:50:23 foser Exp $
+
+inherit gnome2
+
+DESCRIPTION="A music and playlist organizer and player"
+HOMEPAGE="http://web.rhythmbox.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="oggvorbis mad xine"
+
+RDEPEND=">=x11-libs/gtk+-2.2
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libbonoboui-2.0
+ >=gnome-base/gconf-2.0
+ >=media-libs/flac-1.0
+ >=media-libs/musicbrainz-2.0
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ mad? ( >=media-libs/libid3tag-0.15 )
+ !xine? ( >=media-libs/gstreamer-0.6.3
+ >=media-libs/gst-plugins-0.6.3
+ >=media-libs/gst-plugins-gnomevfs-0.6.3
+ mad? ( >=media-libs/gst-plugins-mad-0.6.3 )
+ oggvorbis? ( >=media-libs/gst-plugins-vorbis-0.6.3 )
+ )
+ xine? ( >=media-libs/xine-lib-1_rc0 )"
+# >=media-plugins/gst-plugins-flac-0.6.3
+# should we really force flac ?
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+use xine && G2CONF="${G2CONF} --enable-xine"
+
+G2CONF="${G2CONF} \
+ $(use_enable oggvorbis vorbis) \
+ $(use_enable mad mp3) \
+ --disable-schemas-install"
+
+src_unpack( ) {
+
+ unpack ${A}
+
+ cd ${S}
+ # sandbox errors work around
+ gnome2_omf_fix ${S}/help/C/Makefile.in
+
+}
+
+DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \
+ MAINTAINERS NEWS README THANKS TODO"
+
+export GST_INSPECT=/bin/true