summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-28 13:44:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-28 13:44:23 +0000
commit86fefc8d8e67776569968a3adc5616ea1ff27671 (patch)
treeaeaca74a5f3b14742a87c83673e8cffb26a4ef4b
parentRestrict Python 3.* ABIs (bug #304641). (diff)
downloadhistorical-86fefc8d8e67776569968a3adc5616ea1ff27671.tar.gz
historical-86fefc8d8e67776569968a3adc5616ea1ff27671.tar.bz2
historical-86fefc8d8e67776569968a3adc5616ea1ff27671.zip
Delete older ebuild.
-rw-r--r--dev-python/pysvn/pysvn-1.7.1.ebuild102
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.ebuild39
2 files changed, 0 insertions, 141 deletions
diff --git a/dev-python/pysvn/pysvn-1.7.1.ebuild b/dev-python/pysvn/pysvn-1.7.1.ebuild
deleted file mode 100644
index ce9e6249f853..000000000000
--- a/dev-python/pysvn/pysvn-1.7.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.1.ebuild,v 1.2 2009/11/07 20:10:08 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils multilib python toolchain-funcs
-
-DESCRIPTION="Object-oriented python bindings for subversion"
-HOMEPAGE="http://pysvn.tigris.org/"
-SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~ppc-macos"
-IUSE="doc examples"
-
-DEPEND="dev-util/subversion
- >=dev-python/pycxx-5.5.0"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # Skip test test-06 if executed as root to avoid failure.
- epatch "${FILESDIR}/${P}-skip_root_test.patch"
-
- epatch "${FILESDIR}/${PN}-1.7.0-darwin-freebsd.patch"
-
- # Don't use internal copy of dev-python/pycxx.
- rm -fr Import
-
- python_copy_sources --no-link
-
- preparation() {
- cd Source
- if has "${PYTHON_ABI}" 2.4 2.5; then
- "$(PYTHON)" setup.py backport || die "Backport failed"
- fi
- }
- python_execute_function -s preparation
-}
-
-src_configure() {
- configuration() {
- cd Source
- "$(PYTHON)" setup.py configure --apr-inc-dir="${EPREFIX}/usr/include/apr-1" --svn-root-dir="${EPREFIX}/usr" || die "Configuration failed with Python {PYTHON_ABI}"
-
- sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
- -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
- -e "/^CCC=/s:g++:$(tc-getCXX):" \
- -e "/^CC=/s:gcc:$(tc-getCC):" \
- -e "/^LDSHARED=/s:g++:$(tc-getCXX):" \
- -i Makefile \
- || die "sed failed in Makefile"
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- building() {
- cd Source
- emake
- }
- python_execute_function -s building
-}
-
-src_test() {
- testing() {
- cd Source
- emake test || die "test-pysvn.so failed with Python ${PYTHON_ABI}"
- emake -C ../Tests || die "Tests failed with Python ${PYTHON_ABI}"
- }
- python_execute_function -s testing
-}
-
-src_install() {
- installation() {
- cd Source/pysvn
- exeinto "$(python_get_sitedir)/pysvn"
- doexe _pysvn*$(get_modname) || die "doexe failed"
- insinto "$(python_get_sitedir)/pysvn"
- doins __init__.py || die "doins failed"
- }
- python_execute_function -s installation
-
- if use doc; then
- dohtml -r Docs/ || die "dohtml failed"
- fi
-
- if use examples; then
- docinto examples
- dodoc Examples/Client/* || die "dodoc examples failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize pysvn
-}
-
-pkg_postrm() {
- python_mod_cleanup pysvn
-}
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.ebuild
deleted file mode 100644
index c0bd16368c5f..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.ebuild,v 1.3 2010/02/08 08:44:19 pva Exp $
-
-EAPI="2"
-
-NEED_PYTHON="2.5"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils distutils
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/wiki/Home http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64"
-RESTRICT_PYTHON_ABIS="2.4"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="ptrace"
-
-src_prepare() {
- python_copy_sources --no-link
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
- 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
- epatch python3.0.patch
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}