summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-14 20:12:20 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-14 20:12:20 +0000
commit8517e5064d7e89b18832eade275ae29bf240a305 (patch)
tree23e70f206ee92d8c916e341b5de9b51dd9d73360
parentremoved glitz and on-the-fly-crypt from use.masked (diff)
downloadhistorical-8517e5064d7e89b18832eade275ae29bf240a305.tar.gz
historical-8517e5064d7e89b18832eade275ae29bf240a305.tar.bz2
historical-8517e5064d7e89b18832eade275ae29bf240a305.zip
fix src_test for cross-compilers
Package-Manager: portage-2.1_pre3-r1
-rw-r--r--sys-libs/glibc/Manifest18
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r3.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r1.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r2.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.6.ebuild24
7 files changed, 93 insertions, 69 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 3663e493ec90..3363513a95a0 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -132,20 +132,20 @@ MD5 e67d64767c058da9a992f207155d0650 glibc-2.3.4.20040808-r1.ebuild 27869
MD5 c9960e58c934162d756bc22d4e0047a9 glibc-2.3.4.20041102-r1.ebuild 34434
MD5 d0501b95beefec42d574b34ef0d0cecb glibc-2.3.4.20041102-r2.ebuild 41390
MD5 dcc9e5194707e88476804f3a43d65517 glibc-2.3.4.20050125-r1.ebuild 39583
-MD5 2c351f21ac2aa94aa3801eeb528dac83 glibc-2.3.5-r1.ebuild 40914
-MD5 b9ee683d414edf5d7ac7b7a7d1d28462 glibc-2.3.5-r2.ebuild 39240
-MD5 8b3c88826ef7d6a8e86e938744ac743b glibc-2.3.5-r3.ebuild 39331
+MD5 44f39e42f8ba51393ae4a1d9fc439732 glibc-2.3.5-r1.ebuild 40989
+MD5 8f1d6087f92a4a68c8b619349383b813 glibc-2.3.5-r2.ebuild 39315
+MD5 cbd7d01221758d8f9ad267cbb9bd7ef2 glibc-2.3.5-r3.ebuild 39406
MD5 702c30c61eb97343e09dfde1033342b6 glibc-2.3.5.20050421.ebuild 40128
MD5 7b8266a1773efaae98829ae076e68fe4 glibc-2.3.5.20050722.ebuild 39275
MD5 23af2c26bf05b7b899e05875ebc22af5 glibc-2.3.5.ebuild 40252
-MD5 eda74bd287fa9fdba859a75db1db5029 glibc-2.3.6-r1.ebuild 42180
-MD5 5aa867ba2a4d45b2c00ab43022b8ceac glibc-2.3.6-r2.ebuild 42683
-MD5 011c18760e5b8e0e104ee159bad15982 glibc-2.3.6.ebuild 40508
+MD5 cb57fb7f5c1539a9e483f18969f24285 glibc-2.3.6-r1.ebuild 42255
+MD5 ba4b7640ecd82c004c0c92b4bba33497 glibc-2.3.6-r2.ebuild 42758
+MD5 fdddacb97eda345a5ddb2fa326f70d15 glibc-2.3.6.ebuild 40583
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDx5pf2+ySkm8kpY0RArJ5AJ0VSU9i1/2mgDIuvJeysUxVd+ZcPgCfev6A
-R7qq+1m9NDXLYkEUIiHYRU0=
-=r4+M
+iD8DBQFDyVuR2+ySkm8kpY0RAq3BAKC/w08fQV73bGK8UN7CtrotAceJkgCgrAOW
+hEQwuIhGEf+E1zg6/dHpVuA=
+=Kz0t
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index 554acbbbabb6..8e46a9edf3be 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.48 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.49 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1242,16 +1242,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index 83fd946346a0..de878b4575ee 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.23 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.24 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1191,16 +1191,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.5-r3.ebuild b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
index b01329dc382a..0b36dcc8dba3 100644
--- a/sys-libs/glibc/glibc-2.3.5-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.13 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.14 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1195,16 +1195,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.6-r1.ebuild b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
index 7976a7512ad9..9e67e1dde299 100644
--- a/sys-libs/glibc/glibc-2.3.6-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.11 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.12 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1268,16 +1268,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.6-r2.ebuild b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
index 90d2e166966c..740018fd239d 100644
--- a/sys-libs/glibc/glibc-2.3.6-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.6 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.7 2006/01/14 20:12:20 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -1276,16 +1276,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.6.ebuild b/sys-libs/glibc/glibc-2.3.6.ebuild
index 56723ffecd14..24dc4a946234 100644
--- a/sys-libs/glibc/glibc-2.3.6.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.12 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.13 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1221,16 +1221,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}