summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2006-01-24 16:48:32 +0000
committerWolfram Schlich <wschlich@gentoo.org>2006-01-24 16:48:32 +0000
commit298684563a9c4529a4ca9d7033cba99d6f7dcc40 (patch)
tree4cb4e3a133e8e1a15c044adabd1457043cee3038
parentRemove eselect-php, take 2. (diff)
downloadhistorical-298684563a9c4529a4ca9d7033cba99d6f7dcc40.tar.gz
historical-298684563a9c4529a4ca9d7033cba99d6f7dcc40.tar.bz2
historical-298684563a9c4529a4ca9d7033cba99d6f7dcc40.zip
version bump
Package-Manager: portage-2.1_pre3-r1
-rw-r--r--sys-fs/dazuko/ChangeLog9
-rw-r--r--sys-fs/dazuko/Manifest6
-rw-r--r--sys-fs/dazuko/dazuko-2.1.1.ebuild56
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.1.11
4 files changed, 68 insertions, 4 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index 3887966d002c..b955e413c34f 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/dazuko
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.1 2005/09/09 20:42:37 wschlich Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.2 2006/01/24 16:48:32 wschlich Exp $
+
+*dazuko-2.1.1 (24 Jan 2006)
+
+ 24 Jan 2006; Wolfram Schlich <wschlich@gentoo.org> +dazuko-2.1.1.ebuild:
+ version bump
*dazuko-2.1.0 (09 Sep 2005)
diff --git a/sys-fs/dazuko/Manifest b/sys-fs/dazuko/Manifest
index 29fdb9b31053..362b47a6757c 100644
--- a/sys-fs/dazuko/Manifest
+++ b/sys-fs/dazuko/Manifest
@@ -1,4 +1,6 @@
-MD5 099358dbc4535c4ca0965cb8ee2b98a1 metadata.xml 985
-MD5 271dee1d1064bfeee7dcd31037cff627 ChangeLog 340
+MD5 3b592f1b13a2ebe93c5a0a7b75e62e54 ChangeLog 460
MD5 d6b204957b957752d4e53a0668d97f55 dazuko-2.1.0.ebuild 1297
+MD5 1b9354f203aea8833df78ae18eccd7b4 dazuko-2.1.1.ebuild 1297
MD5 c66de473433fc5ed24d6c9f4ebc9ebef files/digest-dazuko-2.1.0 64
+MD5 4d5e347e86ed8e8ecb7a7d929a2fb8e2 files/digest-dazuko-2.1.1 64
+MD5 099358dbc4535c4ca0965cb8ee2b98a1 metadata.xml 985
diff --git a/sys-fs/dazuko/dazuko-2.1.1.ebuild b/sys-fs/dazuko/dazuko-2.1.1.ebuild
new file mode 100644
index 000000000000..36be7421a357
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.1.1.ebuild,v 1.1 2006/01/24 16:48:32 wschlich Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+# use full kernel version as SLOT, preventing removal of dazuko
+# modules for previously used kernels
+SLOT="${KV_FULL:-0}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=">=virtual/linux-sources-2.2"
+S="${WORKDIR}/${MY_P}"
+
+# kernel settings
+CONFIG_CHECK="SECURITY_CAPABILITIES"
+MODULE_NAMES="dazuko(misc:)"
+BUILD_TARGETS="dummy_rule"
+
+# TODO add 'example' USE flag, install example source code
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ || die "configure failed"
+ convert_to_m Makefile
+ linux-mod_src_compile
+
+ cd library && emake && cd ..
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+# dodoc LICENSE.BSD
+# dodoc LICENSE.GPL
+}
+
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.1.1 b/sys-fs/dazuko/files/digest-dazuko-2.1.1
new file mode 100644
index 000000000000..a9eeae35f680
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.1.1
@@ -0,0 +1 @@
+MD5 35ff694434dedb25fe43dad8db4eb943 dazuko-2.1.1.tar.gz 162359