summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-05-08 22:50:37 +0000
committerMichael Imhof <tantive@gentoo.org>2003-05-08 22:50:37 +0000
commit0f02a48ea041727e81a658ffe03264450f0c94e4 (patch)
tree2bcb5efe402c735ad7beedfab6800c403f584b4a
parentcleaned out old ebuilds (diff)
downloadhistorical-0f02a48ea041727e81a658ffe03264450f0c94e4.tar.gz
historical-0f02a48ea041727e81a658ffe03264450f0c94e4.tar.bz2
historical-0f02a48ea041727e81a658ffe03264450f0c94e4.zip
Closes #20481
-rw-r--r--app-admin/openmosixview/files/digest-openmosixview-1.4-r11
-rw-r--r--app-admin/openmosixview/files/openmosixcollector.init29
-rw-r--r--app-admin/openmosixview/openmosixview-1.4-r1.ebuild83
3 files changed, 113 insertions, 0 deletions
diff --git a/app-admin/openmosixview/files/digest-openmosixview-1.4-r1 b/app-admin/openmosixview/files/digest-openmosixview-1.4-r1
new file mode 100644
index 000000000000..85ec197ac0b0
--- /dev/null
+++ b/app-admin/openmosixview/files/digest-openmosixview-1.4-r1
@@ -0,0 +1 @@
+MD5 2e8fe16860cc9581194bf14bb4896b1d openmosixview-1.4.tar.gz 2935290
diff --git a/app-admin/openmosixview/files/openmosixcollector.init b/app-admin/openmosixview/files/openmosixcollector.init
new file mode 100644
index 000000000000..2b4b380005c2
--- /dev/null
+++ b/app-admin/openmosixview/files/openmosixcollector.init
@@ -0,0 +1,29 @@
+#! /bin/sh
+
+PATH=$PATH:/usr/local/bin
+
+case "$1" in
+ start)
+ echo -n "starting openmosixcollector"
+ openmosixcollector -d
+ ;;
+ stop)
+ echo -n "stopping openmosixcollector"
+ openmosixcollector -k
+ ;;
+ checkpoint)
+ echo -n "checkpointing openmosixcollector"
+ openmosixcollector -c
+ ;;
+ restart)
+ echo -n "restarting openmosixcollector"
+ openmosixcollector -r
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|checkpoint|restart}"
+ exit 1
+ ;;
+esac
+
+
+
diff --git a/app-admin/openmosixview/openmosixview-1.4-r1.ebuild b/app-admin/openmosixview/openmosixview-1.4-r1.ebuild
new file mode 100644
index 000000000000..2a04f5440124
--- /dev/null
+++ b/app-admin/openmosixview/openmosixview-1.4-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixview/openmosixview-1.4-r1.ebuild,v 1.1 2003/05/08 22:50:37 tantive Exp $
+
+S=${WORKDIR}/openmosixview-${PV}
+DESCRIPTION="cluster-management GUI for OpenMosix"
+SRC_URI="www.openmosixview.com/download/openmosixview-${PV}.tar.gz"
+HOMEPAGE="http://www.openmosixview.com"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-2.3.0
+ >=sys-cluster/openmosix-user-0.2.4
+ >=sys-kernel/openmosix-sources-2.4.18"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -alpha"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack openmosixview-${PV}.tar.gz
+
+ cat > configuration << EOF
+ # test which version of qt is installed
+ if [ -d /usr/qt/3 ]; then
+ QTDIR=/usr/qt/3; else
+ QTDIR=/usr/qt/2;
+ fi
+ CC=gcc
+EOF
+}
+
+src_compile() {
+ cd ${S}
+ autoconf || die
+ ./configure || die
+ make || die
+ for x in openmosixcollector openmosixanalyzer openmosixhistory openmosixprocs openmosixmigmon
+ do
+ cd ${S}/${x}
+ autoconf || die
+ ./configure || die
+ make || die
+ done
+}
+
+src_install() {
+ dodir /usr/sbin
+ dodir /usr/local/bin
+
+ make INSTALLBASEDIR=${D}usr INSTALLMANDIR=${D}usr/share/man DESTDIR=${D} INSTALLDIR=${D}usr install || die
+ for y in openmosixcollector openmosixanalyzer openmosixhistory openmosixprocs openmosixmigmon
+ do
+ cd ${S}/${y}
+ make INSTALLBASEDIR=${D}usr INSTALLMANDIR=${D}usr/share/man DESTDIR=${D} INSTALLDIR=${D}usr install || die
+ done
+
+ dodoc COPYING README
+
+ exeinto /etc/init.d
+ rm ${D}/etc/init.d/openmosixcollector
+ newexe ${FILESDIR}/openmosixcollector.init openmosixcollector
+
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Openmosixview will allow you to monitor all nodes in your cluster."
+ einfo
+ einfo "You will need ssh to all cluster-nodes without password."
+ einfo
+ einfo "To setup your other nodes you will have to copy the"
+ einfo "openmosixprocs binary onto each node"
+ einfo "(scp /usr/local/bin/openmosixprocs your_node:/usr/local/bin/openmosixprocs)"
+ einfo
+ einfo "Start openmosixcollector"
+ einfo "manually (/etc/init.d/openmosixcollector start) or"
+ einfo "automatically using rc-update"
+ einfo "(rc-update add /etc/init.d/openmosixcollector default)."
+ einfo
+ einfo "Run openmosixview by simply typing openmosixview."
+ einfo
+}