summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/QGnomePlatform/Manifest1
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/Manifest b/x11-themes/QGnomePlatform/Manifest
index 237df152cbb0..a007d7cd8d40 100644
--- a/x11-themes/QGnomePlatform/Manifest
+++ b/x11-themes/QGnomePlatform/Manifest
@@ -1,2 +1,3 @@
DIST QGnomePlatform-0.3.tar.gz 20499 BLAKE2B 3f30a0e0741b70d3648d9e653bacc08d38e1093977c93e73786e6c72fa254e1b1355e7d4b4bf9c899aff9a019fba34de6e87a178de1b9b093ddc4d894dcc76df SHA512 770ab8f11285856fdec574779905d2a78b2db0d4e515cd6a96e56ccdec6cfc837b31d82eed8af3f6bb860597195cac2869a527d784558c05b9a394687a4ee9d8
DIST QGnomePlatform-0.4.tar.gz 21353 BLAKE2B 185a67f2008f1def0dbe201b29d7c95dbd3c449fcea88048e729f6f3e79da1a73264afdb47580bab34206350c621420fdba4932435f86837329dad91febf2de6 SHA512 664a0bc7245584e89db9d9283509d2f9bd4f148cd0e0df5b6fc698f6705b1897fed1aff7a3cb1f70e75c21edda4f10c9f1b0dffb019c31dd9dee872f98027675
+DIST QGnomePlatform-0.5.tar.gz 22429 BLAKE2B 9647b57904a22eed327194c58f9072e0852950832d323244bf6a5c55356062e88e837a42d28ac94c7feb9562f156f7204e8ea540e31c07388669bedd2157d0db SHA512 ed45468134ba285dbb5ba32d7d72e55c5cd769d6040c231fc38e3d5fd00a2e70a2d1cac967c4f205a2f0ac74d74a877b962380d14c1f091cdcb841c900ab24f0
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild
new file mode 100644
index 000000000000..43850c02741e
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-5.6:5=
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ INSTALL_ROOT="${D}" default
+}