summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/atop/atop-2.10.0-r1.ebuild8
-rw-r--r--sys-process/atop/atop-2.9.0-r1.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/sys-process/atop/atop-2.10.0-r1.ebuild b/sys-process/atop/atop-2.10.0-r1.ebuild
index c9b216bc2e3f..5d3ecf36942a 100644
--- a/sys-process/atop/atop-2.10.0-r1.ebuild
+++ b/sys-process/atop/atop-2.10.0-r1.ebuild
@@ -53,6 +53,14 @@ src_prepare() {
if use modules ; then
cd "${WORKDIR}"/${NETATOP_P} || die
eapply "${FILESDIR}"/${PN}-2.9.0-netatop-makefile.patch
+
+ sed \
+ -e "s#\`uname -r\`#${KV_FULL}#g" \
+ -e "s#\$(shell uname -r)#${KV_FULL}#g" \
+ -i {.,daemon,module}/Makefile || die
+
+ grep -rq "uname -r" && die "found uname calls"
+
cd "${S}" || die
fi
diff --git a/sys-process/atop/atop-2.9.0-r1.ebuild b/sys-process/atop/atop-2.9.0-r1.ebuild
index 313f9ab42b41..b7d49a35cd46 100644
--- a/sys-process/atop/atop-2.9.0-r1.ebuild
+++ b/sys-process/atop/atop-2.9.0-r1.ebuild
@@ -49,6 +49,14 @@ src_prepare() {
if use modules ; then
cd "${WORKDIR}"/${NETATOP_P} || die
eapply "${FILESDIR}"/${PN}-2.9.0-netatop-makefile.patch
+
+ sed \
+ -e "s#\`uname -r\`#${KV_FULL}#g" \
+ -e "s#\$(shell uname -r)#${KV_FULL}#g" \
+ -i {.,daemon,module}/Makefile || die
+
+ grep -rq "uname -r" && die "found uname calls"
+
cd "${S}" || die
fi