summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sysvinit/sysvinit-3.07-r2.ebuild (renamed from sys-apps/sysvinit/sysvinit-3.07-r1.ebuild)9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-apps/sysvinit/sysvinit-3.07-r1.ebuild b/sys-apps/sysvinit/sysvinit-3.07-r2.ebuild
index 349a3b1db05e..71e4fdb7f074 100644
--- a/sys-apps/sysvinit/sysvinit-3.07-r1.ebuild
+++ b/sys-apps/sysvinit/sysvinit-3.07-r2.ebuild
@@ -187,4 +187,13 @@ pkg_postinst() {
if [[ ! -e "${EROOT}/var/log/boot" ]] ; then
touch "${EROOT}/var/log/boot"
fi
+
+ local ver
+ for ver in ${REPLACING_VERSIONS}; do
+ ver_test ${ver} -ge 3.07-r2 && continue
+ ewarn "Previously, the 'halt' command caused the system to power off"
+ ewarn "even if option -p was not given. This long-standing bug has"
+ ewarn "been fixed, and the command now behaves as documented."
+ break
+ done
}