summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/soapyrtlsdr/soapyrtlsdr-0.2.4.ebuild')
-rw-r--r--net-wireless/soapyrtlsdr/soapyrtlsdr-0.2.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-wireless/soapyrtlsdr/soapyrtlsdr-0.2.4.ebuild b/net-wireless/soapyrtlsdr/soapyrtlsdr-0.2.4.ebuild
new file mode 100644
index 000000000000..0527f6ff8d21
--- /dev/null
+++ b/net-wireless/soapyrtlsdr/soapyrtlsdr-0.2.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="SoapySDR RTL-SDR Support Module"
+HOMEPAGE="https://github.com/pothosware/SoapyRTLSDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyRTLSDR.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyRTLSDR/archive/soapy-rtlsdr-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyRTLSDR-soapy-rtlsdr-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-wireless/rtl-sdr"
+DEPEND="${RDEPEND}"