summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sshpass')
-rw-r--r--net-misc/sshpass/Manifest1
-rw-r--r--net-misc/sshpass/files/sshpass-1.04-ssh5.6.patch16
-rw-r--r--net-misc/sshpass/metadata.xml18
-rw-r--r--net-misc/sshpass/sshpass-1.05.ebuild17
4 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/sshpass/Manifest b/net-misc/sshpass/Manifest
new file mode 100644
index 000000000000..1235192253c6
--- /dev/null
+++ b/net-misc/sshpass/Manifest
@@ -0,0 +1 @@
+DIST sshpass-1.05.tar.gz 98362 SHA256 c3f78752a68a0c3f62efb3332cceea0c8a1f04f7cf6b46e00ec0c3000bc8483e SHA512 92ff3428a3cbc2b517e8ee0a6676b409bac3ec0900bfb370cf3882ccc62017edb695ce00e025f73680e9718e1b0213b2ac1bbd2a2558fe43f0f5a7b0d690c810 WHIRLPOOL 15c951f1c7e66a3967d5ed2c541862b95056faab108976206d6e81e76d6234ff116e7f490925305482238b5c86098a6783a691c8f436d8911ffea159df275ff0
diff --git a/net-misc/sshpass/files/sshpass-1.04-ssh5.6.patch b/net-misc/sshpass/files/sshpass-1.04-ssh5.6.patch
new file mode 100644
index 000000000000..2d02c4ef4bf3
--- /dev/null
+++ b/net-misc/sshpass/files/sshpass-1.04-ssh5.6.patch
@@ -0,0 +1,16 @@
+--- main.c.orig 2011-02-01 10:00:45.571260395 +0000
++++ main.c 2011-02-01 11:14:48.571421997 +0000
+@@ -311,6 +311,11 @@
+
+ int numread=read(fd, buffer, sizeof(buffer) );
+
++ // New versions of ssh probably set the terminal to non-blocking, so we get lots of unused or empty responses.
++ if( numread<0 && errno ==5 ) {
++ return 0;
++ }
++
+ if( numread<0 ) {
+ // Comment no. 3.1416
+ // Select is doing a horrid job of waking us up at the right time - it wakes up with "read ready" when the slave
+
+
diff --git a/net-misc/sshpass/metadata.xml b/net-misc/sshpass/metadata.xml
new file mode 100644
index 000000000000..2461dd9ed7ef
--- /dev/null
+++ b/net-misc/sshpass/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>jingcheng01@gmail.com</email>
+ <name> Jing, Cheng</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sshpass</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/sshpass/sshpass-1.05.ebuild b/net-misc/sshpass/sshpass-1.05.ebuild
new file mode 100644
index 000000000000..fe069cc0341c
--- /dev/null
+++ b/net-misc/sshpass/sshpass-1.05.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Tool for noninteractively performing password authentication with ssh"
+HOMEPAGE="http://sshpass.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~x64-macos"
+IUSE=""
+
+RDEPEND="net-misc/openssh"
+DEPEND=""