summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild')
-rw-r--r--net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild39
1 files changed, 21 insertions, 18 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild b/net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild
index 9b30664564c8..a5d7e8e70ae5 100644
--- a/net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild
+++ b/net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild
@@ -30,26 +30,29 @@ src_configure() {
# okay because we want then force enabled.
# --disable-db-as-registry
# --disable-db-cc-registry
+ local myeconfargs=(
+ --disable-bundled-getopt
+ --disable-bundled-md5
+ --enable-shared
+ --enable-dynamic-load
+ --enable-db-ieee
+ --enable-db-ipv4
+ --enable-db-ipv6
+ --disable-dbip
+ --disable-dbip2
+ --disable-external
+ --disable-ip2location
+ --enable-openssl-evp-md5
+ --enable-openssl-md5
+ $(use_enable geoip)
+ $(use_enable cgi mod_ipv6calc )
+ )
+
if use geoip; then
- myconf=$(use_enable geoip)
- myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
+ myeconfargs+=( "--with-geoip-db=${EPREFIX}/usr/share/GeoIP" )
fi
- econf \
- --disable-bundled-getopt \
- --disable-bundled-md5 \
- --enable-shared \
- --enable-dynamic-load \
- --enable-db-ieee \
- --enable-db-ipv4 \
- --enable-db-ipv6 \
- --disable-dbip \
- --disable-dbip2 \
- --disable-external \
- --disable-ip2location \
- --enable-openssl-evp-md5 \
- --enable-openssl-md5 \
- $(use_enable cgi mod_ipv6calc ) \
- ${myconf}
+
+ econf "${myeconfargs[@]}"
}
src_compile() {