summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/croc/croc-9.5.2.ebuild')
-rw-r--r--net-misc/croc/croc-9.5.2.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-misc/croc/croc-9.5.2.ebuild b/net-misc/croc/croc-9.5.2.ebuild
deleted file mode 100644
index 03dce788293d..000000000000
--- a/net-misc/croc/croc-9.5.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 go-module systemd
-
-DESCRIPTION="Easily and securely send things from one computer to another"
-HOMEPAGE="https://github.com/schollz/croc"
-
-SRC_URI="https://github.com/schollz/croc/releases/download/v${PV}/${PN}_${PV}_src.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
-
-RDEPEND="
- acct-group/croc
- acct-user/croc
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-disable-network-tests-r1.patch"
-)
-
-DOCS=( README.md )
-
-src_prepare() {
- default
- # Replace User=nobody with User=croc
- sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
- # Rename bash completion function
- sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
- src/install/bash_autocomplete || die
-}
-
-src_compile() {
- ego build
-}
-
-src_install() {
- dobin croc
- systemd_dounit croc.service
- newbashcomp src/install/bash_autocomplete croc
- einstalldocs
-}
-
-src_test() {
- ego test -work ./...
-}