summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/toxic-0.11.1-r1.ebuild (renamed from net-im/toxic/toxic-0.11.1.ebuild)4
-rw-r--r--net-im/toxic/toxic-0.11.3-r1.ebuild (renamed from net-im/toxic/toxic-0.11.3.ebuild)4
2 files changed, 6 insertions, 2 deletions
diff --git a/net-im/toxic/toxic-0.11.1.ebuild b/net-im/toxic/toxic-0.11.1-r1.ebuild
index fead2de553a3..1a535eb7fcaa 100644
--- a/net-im/toxic/toxic-0.11.1.ebuild
+++ b/net-im/toxic/toxic-0.11.1-r1.ebuild
@@ -101,7 +101,9 @@ src_configure() {
if ! use X; then
export DISABLE_X11=1
fi
- export USER_CFLAGS="${CFLAGS}"
+ #include strings.h fixes undefined reference to strcasecmp()
+ #defining _GNU_SOURCE fixes undefined reference to strcasestr()
+ export USER_CFLAGS="${CFLAGS} -include strings.h -D _GNU_SOURCE"
export USER_LDFLAGS="${LDFLAGS}"
#set install directory to /usr.
sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"
diff --git a/net-im/toxic/toxic-0.11.3.ebuild b/net-im/toxic/toxic-0.11.3-r1.ebuild
index a436039ffa9e..4a42d75791c5 100644
--- a/net-im/toxic/toxic-0.11.3.ebuild
+++ b/net-im/toxic/toxic-0.11.3-r1.ebuild
@@ -101,7 +101,9 @@ src_configure() {
if ! use X; then
export DISABLE_X11=1
fi
- export USER_CFLAGS="${CFLAGS}"
+ #Including strings.h fixes undefined reference to strcasecmp()
+ #Defining _GNU_SOURCE fixes undefined reference to strcasestr()
+ export USER_CFLAGS="${CFLAGS} -include strings.h -D _GNU_SOURCE"
export USER_LDFLAGS="${LDFLAGS}"
#set install directory to /usr.
sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"