summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mk-livestatus')
-rw-r--r--net-analyzer/mk-livestatus/Manifest1
-rw-r--r--net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff23
-rw-r--r--net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-test-RequireRcsKeywords.diff18
-rw-r--r--net-analyzer/mk-livestatus/metadata.xml7
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild126
5 files changed, 175 insertions, 0 deletions
diff --git a/net-analyzer/mk-livestatus/Manifest b/net-analyzer/mk-livestatus/Manifest
new file mode 100644
index 000000000000..69d35d5a746e
--- /dev/null
+++ b/net-analyzer/mk-livestatus/Manifest
@@ -0,0 +1 @@
+DIST mk-livestatus-1.2.2p3.tar.gz 382030 SHA256 edceb13675ed3375fd867216e2ffe31c350d5860509f9fb0abd182148e270616 SHA512 ee3468de5a61c4aa904d8d0df8e4a66c56a04e2f99d92237957100dc7ecb28e8e1f403488298b5a92ce78874e176384eca02eeb9b0a99c1bbf9799a9c2fcaa01 WHIRLPOOL 7fe080bbfc2d04a037248a94a202137cdc0ca40689800e51c273bd83dfe4e5c2e5d54ca6ff525d6ffb5015ff6032b8cfe65739896a63adaf01a7d550f771d8e4
diff --git a/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff
new file mode 100644
index 000000000000..a3f81a5054cb
--- /dev/null
+++ b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff
@@ -0,0 +1,23 @@
+--- src/Makefile.am 2013-08-20 14:24:46.000000000 +0200
++++ src/Makefile.am 2013-08-20 14:25:20.000000000 +0200
+@@ -54,9 +54,9 @@
+
+ livecheck$(EXEEXT): livecheck.c strutil.c check_icmp.c
+ if HAVE_DIET
+- diet -v $(CC) -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -s -o $@ $^
++ diet -v $(CC) -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -o $@ $^
+ else
+- $(CC) -x c -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -s -o $@ $^
++ $(CC) -x c -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -o $@ $^
+ endif
+
+ livestatus_so_CXXFLAGS = -I$(top_srcdir)/nagios -fPIC
+@@ -64,7 +64,7 @@
+
+ livestatus.o: $(livestatus_so_OBJECTS) $(livestatus_so_DEPENDENCIES)
+ -rm -f plugin.so
+- $(CXX) $(LDFLAGS) -s -fPIC -shared $(livestatus_so_OBJECTS) -o $@ -lpthread -lstdc++
++ $(CXX) $(LDFLAGS) -fPIC -shared $(livestatus_so_OBJECTS) -o $@ -lpthread -lstdc++
+
+ all-local: livestatus.o
+
diff --git a/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-test-RequireRcsKeywords.diff b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-test-RequireRcsKeywords.diff
new file mode 100644
index 000000000000..95b2830feccf
--- /dev/null
+++ b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-test-RequireRcsKeywords.diff
@@ -0,0 +1,18 @@
+--- ./api/perl/t/perlcriticrc 2013-08-21 22:37:57.791099241 +0200
++++ ./api/perl/t/perlcriticrc 2013-08-21 22:38:02.943210061 +0200
+@@ -133,8 +133,6 @@ severity = 3
+ [Perl::Critic::Policy::Miscellanea::ProhibitTies]
+ severity = 4
+
+-[-Perl::Critic::Policy::Miscellanea::RequireRcsKeywords]
+-
+ [Perl::Critic::Policy::Modules::ProhibitAutomaticExportation]
+ severity = 4
+
+@@ -283,4 +281,4 @@ severity = 5
+ severity = 5
+
+ [Perl::Critic::Policy::Variables::RequireNegativeIndices]
+-severity = 4
+\ No newline at end of file
++severity = 4
diff --git a/net-analyzer/mk-livestatus/metadata.xml b/net-analyzer/mk-livestatus/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/net-analyzer/mk-livestatus/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild
new file mode 100644
index 000000000000..6e506632c963
--- /dev/null
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+PERL_EXPORT_PHASE_FUNCTIONS=no
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools perl-module python-r1 eutils
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Nagios/Icinga event broker module that allows quick/direct access to your status data"
+HOMEPAGE="http://mathias-kettner.de/checkmk_livestatus.html"
+SRC_URI="http://mathias-kettner.de/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples perl python test"
+
+RDEPEND="perl? (
+ dev-lang/perl:0
+ virtual/perl-Digest-MD5:0
+ virtual/perl-Scalar-List-Utils:0
+ >=virtual/perl-Thread-Queue-2.11:0
+ virtual/perl-Encode:0
+ dev-perl/JSON-XS:0
+ )"
+DEPEND="${RDEPEND}
+ perl? (
+ dev-perl/Module-Install:0
+ virtual/perl-ExtUtils-MakeMaker:0
+ virtual/perl-File-Path:0
+ virtual/perl-File-Spec:0
+ virtual/perl-File-Temp:0
+ test? (
+ dev-perl/File-Copy-Recursive:0
+ dev-perl/Test-Pod:0
+ dev-perl/Test-Perl-Critic:0
+ dev-perl/Test-Pod-Coverage:0
+ dev-perl/Perl-Critic:0
+ dev-perl/Perl-Critic-Policy-Dynamic-NoIndirect:0
+ dev-perl/Perl-Critic-Deprecated:0
+ dev-perl/Perl-Critic-Nits:0
+ )
+ )"
+
+# For perl test
+SRC_TEST="parallel"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Use system Module::Install instead, it will be copied to $S by
+ # Module::install itself.
+ rm -rf api/perl/inc
+
+ if use perl; then
+ perl-module_src_prepare
+ fi
+
+ epatch "${FILESDIR}/${P}-no-strip.diff"
+ epatch "${FILESDIR}/${P}-test-RequireRcsKeywords.diff"
+
+ # Script too old
+ rm -f missing
+
+ eautoreconf
+}
+
+src_configure() {
+ econf
+
+ if use perl; then
+ cd api/perl/
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ emake
+
+ if use perl; then
+ cd api/perl
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ if use perl; then
+ cd api/perl
+
+ export TEST_AUTHOR="Test Author"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ emake -C src/ DESTDIR="${ED}" install-binPROGRAMS install-data-local
+
+ if use perl; then
+ cd api/perl
+ perl-module_src_install
+ cd "${S}"
+
+ if use examples; then
+ docinto examples/
+ dodoc api/perl/examples/dump.pl
+ fi
+ fi
+
+ if use python; then
+ python_foreach_impl python_domodule api/python/livestatus.py
+
+ if use examples; then
+ newdoc api/python/README README.python
+
+ docinto examples/
+ dodoc api/python/{example,example_multisite,make_nagvis_map}.py
+ fi
+ fi
+}