summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dolphin')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index b12563f7dd2f..981b451e4d5b 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -4,9 +4,11 @@
EAPI=5
+PLOCALES="ar ca cs de el en es fa fr he hu it ja ko nb nl pl pt_BR pt ru sr sv tr zh_CN zh_TW"
+PLOCALE_BACKUP="en"
WX_GTK_VER="3.0"
-inherit cmake-utils eutils pax-utils toolchain-funcs versionator wxwidgets games
+inherit cmake-utils eutils l10n pax-utils toolchain-funcs versionator wxwidgets games
if [[ ${PV} == 9999* ]]
then
@@ -130,6 +132,18 @@ src_prepare() {
mv SOIL Externals || die
mv gtest Externals || die
mv xxhash Externals || die
+
+ remove_locale() {
+ # Ensure preservation of the backup locale when no valid LINGUA is set
+ if [[ "${PLOCALE_BACKUP}" == "${1}" ]] && [[ "${PLOCALE_BACKUP}" == "$(l10n_get_locales)" ]]; then
+ return
+ else
+ rm "Languages/po/${1}.po" || die
+ fi
+ }
+
+ l10n_find_plocales_changes "Languages/po/" "" '.po'
+ l10n_for_each_disabled_locale_do remove_locale
}
src_configure() {