summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/codeblocks/codeblocks-13.12-r1.ebuild42
-rw-r--r--dev-util/codeblocks/codeblocks-9999.ebuild4
2 files changed, 2 insertions, 44 deletions
diff --git a/dev-util/codeblocks/codeblocks-13.12-r1.ebuild b/dev-util/codeblocks/codeblocks-13.12-r1.ebuild
deleted file mode 100644
index fa0a728898c8..000000000000
--- a/dev-util/codeblocks/codeblocks-13.12-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-WX_GTK_VER="3.0"
-
-inherit eutils wxwidgets
-
-DESCRIPTION="The open source, cross platform, free C++ IDE"
-HOMEPAGE="http://www.codeblocks.org/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
-SRC_URI="mirror://sourceforge/codeblocks/${P/-/_}-1.tar.gz"
-
-IUSE="contrib debug pch static-libs"
-
-RDEPEND="app-arch/zip
- x11-libs/wxGTK:${WX_GTK_VER}[X]
- contrib? (
- app-text/hunspell
- dev-libs/boost:=
- dev-libs/libgamin
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- need-wxwidgets unicode
- econf \
- --with-wx-config="${WX_CONFIG}" \
- $(use_enable debug) \
- $(use_enable pch) \
- $(use_enable static-libs static) \
- $(use_with contrib contrib-plugins all)
-}
-
-src_install() {
- default
- prune_libtool_files
-}
diff --git a/dev-util/codeblocks/codeblocks-9999.ebuild b/dev-util/codeblocks/codeblocks-9999.ebuild
index d103c986e13c..6504279fb352 100644
--- a/dev-util/codeblocks/codeblocks-9999.ebuild
+++ b/dev-util/codeblocks/codeblocks-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-WX_GTK_VER="3.0"
+WX_GTK_VER="2.8"
inherit autotools eutils subversion wxwidgets