summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twill')
-rw-r--r--dev-python/twill/Manifest1
-rw-r--r--dev-python/twill/metadata.xml9
-rw-r--r--dev-python/twill/twill-0.9-r1.ebuild41
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/twill/Manifest b/dev-python/twill/Manifest
new file mode 100644
index 000000000000..566d4b10ae82
--- /dev/null
+++ b/dev-python/twill/Manifest
@@ -0,0 +1 @@
+DIST twill-0.9.tar.gz 242291 SHA256 8053c25fd6edf6ddf5e7583224e7b23ad947df1f90175b018af5cf7abeb42a86 SHA512 ea47400e236c4f5a4d38671bbc5690d004c4dbd20b6152c54c2fa64bae3e3ec68d16a5305d42e8631595cac25f5b2a08e0eb287b7e1ed7b90a8368d6063b1f1e WHIRLPOOL ee306acc4434b919119fa103d15f82909490b57440d61dc4193af3d11827759202949a8e568b356fcd52a34ec791f5f5adeedf7848471fe13f53fa7dbebc7ad3
diff --git a/dev-python/twill/metadata.xml b/dev-python/twill/metadata.xml
new file mode 100644
index 000000000000..9d2a9281f413
--- /dev/null
+++ b/dev-python/twill/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ twill is a simple language that allows users to browse the Web from a command-line interface. With twill, you can navigate through Web sites that use forms, cookies, and most standard Web features. twill supports automated Web testing and has a simple Python interface. Check out the examples! twill is open source and written in Python.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-python/twill/twill-0.9-r1.ebuild b/dev-python/twill/twill-0.9-r1.ebuild
new file mode 100644
index 000000000000..1d397df7a63c
--- /dev/null
+++ b/dev-python/twill/twill-0.9-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Simple scripting language for web browsing with Python API"
+HOMEPAGE="http://twill.idyll.org/"
+SRC_URI="http://darcs.idyll.org/~t/projects/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86"
+IUSE="doc examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( $(python_gen_cond_dep 'dev-python/epydoc[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/dnspython[${PYTHON_USEDEP}]' python2_7) )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ pushd doc > /dev/null
+ chmod +x make-epydoc.sh
+ ./make-epydoc.sh
+ popd> /dev/null
+ fi
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/epydoc-html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}