summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/singledispatch')
-rw-r--r--dev-python/singledispatch/Manifest1
-rw-r--r--dev-python/singledispatch/metadata.xml20
-rw-r--r--dev-python/singledispatch/singledispatch-3.4.0.3.ebuild20
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/singledispatch/Manifest b/dev-python/singledispatch/Manifest
new file mode 100644
index 000000000000..51f7fc8c00bc
--- /dev/null
+++ b/dev-python/singledispatch/Manifest
@@ -0,0 +1 @@
+DIST singledispatch-3.4.0.3.tar.gz 9529 SHA256 5b06af87df13818d14f08a028e42f566640aef80805c3b50c5056b086e3c2b9c SHA512 ba065d36092ddee6527be3d7cb777c51c0949855bf6dd0ffb7c25acaedaa35d36fe6dc096587acddcd1e9e54c6ac5f92c196b11f9ee1270cc0c1cf2f410446cf WHIRLPOOL 183ff853db1743b9a55023a62afc806d60dc095f8a1a32392ad3d48c31f0c9b2b2001dc9bd264c90dbfc7acb92670342a2ff770886aa81afe9b5badde4dbe22a
diff --git a/dev-python/singledispatch/metadata.xml b/dev-python/singledispatch/metadata.xml
new file mode 100644
index 000000000000..b66ef2454278
--- /dev/null
+++ b/dev-python/singledispatch/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>timo@rothenpieler.org</email>
+ <name>Timo Rothenpieler</name>
+ <description>proxy maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>realnc@gmail.com</email>
+ <name>Nikos Chantziaras</name>
+ <description>proxy maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">singledispatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild b/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
new file mode 100644
index 000000000000..3cb00c89e9e4
--- /dev/null
+++ b/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to bring functools.singledispatch from Python 3.4 to Python 2.6-3.3"
+HOMEPAGE="http://docs.python.org/3/library/functools.html#functools.singledispatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"