summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytools')
-rw-r--r--dev-python/pytools/Manifest1
-rw-r--r--dev-python/pytools/pytools-2024.1.7.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index de282a6bf6a5..f1cad9524054 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1,2 +1,3 @@
DIST pytools-2024.1.5.tar.gz 80774 BLAKE2B 37e9e14d5a62cdad34ddbfd0eabec747c392ba1506aacc76322f090699192369915882ba948fa07cd7a45369d3391343d9b2554def851e844976bc0442ddcfb6 SHA512 af7b79f1e26a43459765627ce6e6740953c38e05e26f3ec17360ccdf588ac320eabb5540fbbf9570cde324b8aae2412878316e9930e5195f467dbf5b74ca76b8
DIST pytools-2024.1.6.tar.gz 81344 BLAKE2B ff68e2606170bf54e3f609ee7f4cfe58e063f43dcfb2706d5ed7659ea2fde863e6315d0d81dff2e62a3378f195413561a927b0c1e7bedc06388cf4893c07b873 SHA512 a9e934f1cbaf0ace32420f9b74224a06ce8421ee291b837292133969c6788c4cc8bea01446cd4d1505aca9fa81e8ae0d3eacf60d3285186e66d67d5abe10ce3e
+DIST pytools-2024.1.7.tar.gz 82211 BLAKE2B 07da2dbd2d19ec11a481f71aac1273f64e3eb00483b1a633d42a08e36aa8d76e0cae0235538f58d0c2acf12079544b168a97d78c9aa1d3421525e6fe47f1db82 SHA512 9833cf5c3b72cb89bf25dde5f15c5970db5dd86e1eaf1dbfb8e7024ac0854fa200f6bb64f8ebd346998c4ca792ee0dca898b0de0f839445c64e2279dcc771788
diff --git a/dev-python/pytools/pytools-2024.1.7.ebuild b/dev-python/pytools/pytools-2024.1.7.ebuild
new file mode 100644
index 000000000000..bf6b9285b4a4
--- /dev/null
+++ b/dev-python/pytools/pytools-2024.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="
+ https://mathema.tician.de/software/pytools/
+ https://github.com/inducer/pytools/
+ https://pypi.org/project/pytools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# NB: numpy is now an "extra" (optional) dep -- we can remove it from
+# RDEPEND If revdeps don't need it
+RDEPEND="
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/siphash24-1.6[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest