summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pSQL/pSQL-1.2.0.ebuild')
-rw-r--r--dev-python/pSQL/pSQL-1.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pSQL/pSQL-1.2.0.ebuild b/dev-python/pSQL/pSQL-1.2.0.ebuild
new file mode 100644
index 000000000000..674b2ab45a44
--- /dev/null
+++ b/dev-python/pSQL/pSQL-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="MySQL abstraction layer for python"
+HOMEPAGE="http://software.fionet.com/pSQL/"
+SRC_URI="http://software.fionet.com/pSQL/release/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-python/mysql-python[${PYTHON_USEDEP}]
+ dev-python/egenix-mx-base[${PYTHON_USEDEP}]"
+DEPEND=""
+
+src_install() {
+ python_parallel_foreach_impl python_domodule pSQL.py
+
+ dodoc *pSQL
+}