summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbson/libbson-1.9.3.ebuild')
-rw-r--r--dev-libs/libbson/libbson-1.9.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libbson/libbson-1.9.3.ebuild b/dev-libs/libbson/libbson-1.9.3.ebuild
new file mode 100644
index 000000000000..8d74b74a4e4f
--- /dev/null
+++ b/dev-libs/libbson/libbson-1.9.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A BSON utility library"
+HOMEPAGE="https://github.com/mongodb/libbson"
+SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug examples static-libs"
+
+src_configure() {
+ econf --disable-optimizations \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Installing all the manuals conflicts with man-pages
+ doman doc/man/bson_*.3
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+
+ einstalldocs
+}
+
+src_test() {
+ emake test
+}