summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hunit')
-rw-r--r--dev-haskell/hunit/Manifest1
-rw-r--r--dev-haskell/hunit/files/hunit-1.6.2.0-prevent-abi-change.patch20
-rw-r--r--dev-haskell/hunit/hunit-1.6.2.0-r1.ebuild29
-rw-r--r--dev-haskell/hunit/metadata.xml6
4 files changed, 52 insertions, 4 deletions
diff --git a/dev-haskell/hunit/Manifest b/dev-haskell/hunit/Manifest
index 0ac9512ec4fb..49751e7f2dff 100644
--- a/dev-haskell/hunit/Manifest
+++ b/dev-haskell/hunit/Manifest
@@ -1 +1,2 @@
DIST HUnit-1.6.2.0.tar.gz 21179 BLAKE2B c3a299cbe8f6cfe2859baf1c8a212420fd745cb5927d54ad8aae5d13dfc657a27b972de73b405d1464695405ba932e6bfd2073386e0bb9b1f398178ef1a7ba2d SHA512 b27c33545fcb4ca78dd9543eb0ab2f09e5edd989d116fe2136d876eb94745e6d384967ea4b3c6dbf0f03511091a82ecd0b299c8ab00769c57d6dddcddc27e8e5
+DIST hunit-1.6.2.0.tar.gz 21179 BLAKE2B c3a299cbe8f6cfe2859baf1c8a212420fd745cb5927d54ad8aae5d13dfc657a27b972de73b405d1464695405ba932e6bfd2073386e0bb9b1f398178ef1a7ba2d SHA512 b27c33545fcb4ca78dd9543eb0ab2f09e5edd989d116fe2136d876eb94745e6d384967ea4b3c6dbf0f03511091a82ecd0b299c8ab00769c57d6dddcddc27e8e5
diff --git a/dev-haskell/hunit/files/hunit-1.6.2.0-prevent-abi-change.patch b/dev-haskell/hunit/files/hunit-1.6.2.0-prevent-abi-change.patch
new file mode 100644
index 000000000000..42d1027aba22
--- /dev/null
+++ b/dev-haskell/hunit/files/hunit-1.6.2.0-prevent-abi-change.patch
@@ -0,0 +1,20 @@
+From: hololeap <hololeap@protonmail.com>
+Signed-off-by: hololeap <hololeap@protonmail.com>
+
+When dependencies change (for instance switching from USE=-test to USE=test)
+the ABI hash for the package changes, causing reverse-dependencies to break.
+This keeps the dependencies the same whether tests are enabled or not.
+
+diff -urN HUnit-1.6.2.0/HUnit.cabal HUnit-1.6.2.0-r1/HUnit.cabal
+--- HUnit-1.6.2.0/HUnit.cabal 2022-08-28 14:11:57.178837140 -0600
++++ HUnit-1.6.2.0-r1/HUnit.cabal 2022-08-28 14:12:38.558837160 -0600
+@@ -32,7 +32,8 @@
+ build-depends:
+ base ==4.*,
+ call-stack >=0.3.0,
+- deepseq
++ deepseq,
++ filepath
+ exposed-modules:
+ Test.HUnit.Base
+ Test.HUnit.Lang
diff --git a/dev-haskell/hunit/hunit-1.6.2.0-r1.ebuild b/dev-haskell/hunit/hunit-1.6.2.0-r1.ebuild
new file mode 100644
index 000000000000..69a8f58dcad5
--- /dev/null
+++ b/dev-haskell/hunit/hunit-1.6.2.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.2.2.9999
+
+CABAL_PN="HUnit"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A unit testing framework for Haskell"
+HOMEPAGE="https://github.com/hspec/HUnit#readme"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.2.0-prevent-abi-change.patch"
+)
+
+RDEPEND=">=dev-haskell/call-stack-0.3.0:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
diff --git a/dev-haskell/hunit/metadata.xml b/dev-haskell/hunit/metadata.xml
index c659a3510515..f49a11c4e034 100644
--- a/dev-haskell/hunit/metadata.xml
+++ b/dev-haskell/hunit/metadata.xml
@@ -5,11 +5,9 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- HUnit is a unit testing framework for Haskell, inspired by the
- JUnit tool for Java, see: &lt;http://www.junit.org&gt;.
- </longdescription>
<upstream>
+ <remote-id type="hackage">HUnit</remote-id>
+ <remote-id type="github">hspec/HUnit</remote-id>
<remote-id type="sourceforge">hunit</remote-id>
</upstream>
</pkgmetadata>