summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/leo/leo-4.11.ebuild')
-rw-r--r--app-editors/leo/leo-4.11.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/leo/leo-4.11.ebuild b/app-editors/leo/leo-4.11.ebuild
new file mode 100644
index 000000000000..c096d5f55a8f
--- /dev/null
+++ b/app-editors/leo/leo-4.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="tk"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-pypy-* *-jython"
+
+inherit distutils eutils
+
+MY_P="Leo-${PV}-final"
+
+DESCRIPTION="Leo: Literate Editor with Outlines"
+HOMEPAGE="http://leo.sourceforge.net/ http://pypi.python.org/pypi/leo"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="app-text/silvercity
+ dev-python/PyQt4[X]"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+ dohtml -r leo/doc/html/* || die "dohtml failed"
+}