summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/codecrypt/codecrypt-1.6.ebuild')
-rw-r--r--app-crypt/codecrypt/codecrypt-1.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-crypt/codecrypt/codecrypt-1.6.ebuild b/app-crypt/codecrypt/codecrypt-1.6.ebuild
new file mode 100644
index 000000000000..20d2f0053b45
--- /dev/null
+++ b/app-crypt/codecrypt/codecrypt-1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Post-quantum cryptography tool"
+HOMEPAGE="http://e-x-a.org/codecrypt/"
+SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cryptopp"
+
+DEPEND="dev-libs/gmp
+ cryptopp? ( dev-libs/crypto++ )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with cryptopp)
+}