summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/bsign/bsign-0.4.5-r1.ebuild')
-rw-r--r--app-crypt/bsign/bsign-0.4.5-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/app-crypt/bsign/bsign-0.4.5-r1.ebuild b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
index c2b4476d4cd2..2431d369e7f5 100644
--- a/app-crypt/bsign/bsign-0.4.5-r1.ebuild
+++ b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit autotools flag-o-matic eutils toolchain-funcs
+EAPI=6
+inherit autotools flag-o-matic
DESCRIPTION="embed secure hashes (SHA1) and digital signatures (GNU Privacy Guard) into files"
HOMEPAGE="http://packages.debian.org/sid/bsign"
@@ -14,10 +14,15 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86 ~x86-linux"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}"/${P}-non-gnu.patch # for Darwin, BSD, Solaris, etc.
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-scripts.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-non-gnu.patch # for Darwin, BSD, Solaris, etc.
- epatch "${FILESDIR}"/${P}-build.patch
- epatch "${FILESDIR}"/${P}-scripts.patch
+ default
+ mv configure.in configure.ac
eautoreconf
}
@@ -27,8 +32,8 @@ src_configure() {
}
src_install() {
+ einstalldocs
dobin bsign_sign bsign_verify bsign_hash bsign_check
newbin o/bsign-unstripped bsign
doman bsign.1
- dodoc README
}