summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'acct-user/logcheck')
-rw-r--r--acct-user/logcheck/logcheck-0-r2.ebuild (renamed from acct-user/logcheck/logcheck-0-r1.ebuild)8
-rw-r--r--acct-user/logcheck/metadata.xml9
2 files changed, 16 insertions, 1 deletions
diff --git a/acct-user/logcheck/logcheck-0-r1.ebuild b/acct-user/logcheck/logcheck-0-r2.ebuild
index f2635a5ebd27..400eef262709 100644
--- a/acct-user/logcheck/logcheck-0-r1.ebuild
+++ b/acct-user/logcheck/logcheck-0-r2.ebuild
@@ -6,8 +6,16 @@ EAPI=7
inherit acct-user
DESCRIPTION="User for app-admin/logcheck"
+IUSE="systemd"
ACCT_USER_GROUPS=( "logcheck" )
ACCT_USER_ID="284"
acct-user_add_deps
+
+pkg_setup() {
+ # Allow the 'logcheck' user to view the systemd journal.
+ if use systemd; then
+ ACCT_USER_GROUPS+=( systemd-journal )
+ fi
+}
diff --git a/acct-user/logcheck/metadata.xml b/acct-user/logcheck/metadata.xml
index 115e9d64a669..7530d08266f4 100644
--- a/acct-user/logcheck/metadata.xml
+++ b/acct-user/logcheck/metadata.xml
@@ -1,5 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>foti.giuseppe@gmail.com</email>
+ <name>Giuseppe Foti</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
</pkgmetadata>