summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch20
-rw-r--r--dev-python/shiboken/shiboken-1.2.2.ebuild1
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch b/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch
new file mode 100644
index 000000000000..65734232472c
--- /dev/null
+++ b/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch
@@ -0,0 +1,20 @@
+Bug: https://bugs.gentoo.org/619332
+PR: https://github.com/pyside/Shiboken/pull/84
+
+--- a/tests/libsample/simplefile.cpp
++++ b/tests/libsample/simplefile.cpp
+@@ -90,13 +90,13 @@ bool
+ SimpleFile::exists() const
+ {
+ std::ifstream ifile(p->m_filename);
+- return ifile;
++ return static_cast<bool>(ifile);
+ }
+
+ bool
+ SimpleFile::exists(const char* filename)
+ {
+ std::ifstream ifile(filename);
+- return ifile;
++ return static_cast<bool>(ifile);
+ }
diff --git a/dev-python/shiboken/shiboken-1.2.2.ebuild b/dev-python/shiboken/shiboken-1.2.2.ebuild
index 89119cb728f2..65d6d0be4d16 100644
--- a/dev-python/shiboken/shiboken-1.2.2.ebuild
+++ b/dev-python/shiboken/shiboken-1.2.2.ebuild
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog )
PATCHES=(
"${FILESDIR}/${PV}-Fix-tests-with-Python-3.patch"
+ "${FILESDIR}/${P}-gcc6.patch"
)
src_prepare() {