summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/smarty/Manifest1
-rw-r--r--dev-php/smarty/smarty-4.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index fe6283ca44ca..854d81f2df8c 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1 +1,2 @@
DIST smarty-4.2.1.tar.gz 236881 BLAKE2B 4014178cfc4411a9ded3120d0e3e977af0190bc03f6ed21bbd2c484ca8fb4e5aa79fe9c606ee13be87db94c17a00d7d0399cb04fe09c4b439b95bc7b9331d675 SHA512 0d55ab1d329aaa0853a1c40b5b0207d3ddc8b0c25d863a217b3c4ac8bb0a796bb60eda2919b5dda569565b03b8dd44dff67b55d8fafc005164f2848bb481d131
+DIST smarty-4.3.0.tar.gz 360023 BLAKE2B 7f3fbeab71b9deb30242cfaf62a67380397a0ad0ca6c657186aa8150f27df46b33dbe55d32657f71f13ea6fe31d37dbfba44dee43ab21ef6906ba56e1ccdff60 SHA512 7db02a455ab4a6aeb69792f5cdd043a2045fa3a2045d06e1a2423cd4dae48c306be149c25567d1be92f50789e14c4d314b7bd29f3f52b74b00bfeeedc0be7ca9
diff --git a/dev-php/smarty/smarty-4.3.0.ebuild b/dev-php/smarty/smarty-4.3.0.ebuild
new file mode 100644
index 000000000000..312ca47189f6
--- /dev/null
+++ b/dev-php/smarty/smarty-4.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="https://www.smarty.net/ https://github.com/smarty-php/smarty/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ # The smarty docs and examples aren't part of the tarball,
+ # https://github.com/smarty-php/smarty/issues/799
+ local DOCS=( CHANGELOG.md README.md SECURITY.md )
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}