summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pip-run/Manifest2
-rw-r--r--dev-python/pip-run/pip-run-12.6.1.ebuild51
-rw-r--r--dev-python/pip-run/pip-run-12.7.0.ebuild50
3 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 3339f8997739..c1c7616a0c93 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1,3 +1 @@
-DIST pip-run-12.6.1.tar.gz 38868 BLAKE2B 852e8207fc5951a4007f761c18dd06b483a0658d3ab3f51e667b5f0a204fe2f2c530ade5d2d36005c2a25d564cb779b5d2911aeaf5e046477631958172414352 SHA512 b4dcdf0d96061b7049bd8ad25e20f36fe305fe04148937cab3be91ab8fc95849b07b14d2948eb0d5172d36f5ef561b80cff07b1203c62f117c52eb5d265e9356
-DIST pip_run-12.7.0.tar.gz 39346 BLAKE2B 8e3f925310ea07b243f91e4b2afbc3aa87ce3bf2a55e6e9c8e1479f0e5002dd8937808d6c75eeeeb2348d6784c06abfdf78b75931d1de68237956a784c649398 SHA512 81708b966071956f21e0eb12229653171e161835a875182bc317428096b9a67b2272047c09871e216dab75b64c9aa3e50440602634522d217df653cd5175a833
DIST pip_run-13.0.0.tar.gz 38947 BLAKE2B 73a3a2ca97e4a9eab0e32ed487b7b231a92fcb9fa9084eb3f3ffb3b0a1468274fdc0cac530c02dd785b51f7ddc3f24d24feb6a7b38de2e20e893c1618f935ff7 SHA512 9683350d85cbb9298b8844f1b9a71f5d41d13f0812a5416066e731651153a57625a1ee91b37b6cfcf2e83cba3eaa890c078c13f9df8a2812b6070e21a7194d11
diff --git a/dev-python/pip-run/pip-run-12.6.1.ebuild b/dev-python/pip-run/pip-run-12.6.1.ebuild
deleted file mode 100644
index 7483c10f42df..000000000000
--- a/dev-python/pip-run/pip-run-12.6.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Install packages and run Python with them"
-HOMEPAGE="
- https://github.com/jaraco/pip-run/
- https://pypi.org/project/pip-run/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/autocommand[${PYTHON_USEDEP}]
- dev-python/jaraco-context[${PYTHON_USEDEP}]
- dev-python/jaraco-env[${PYTHON_USEDEP}]
- >=dev-python/jaraco-functools-3.7[${PYTHON_USEDEP}]
- dev-python/jaraco-text[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/path[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- dev-python/flit-core[${PYTHON_USEDEP}]
- dev-python/jaraco-path[${PYTHON_USEDEP}]
- >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest -m "not network"
-}
diff --git a/dev-python/pip-run/pip-run-12.7.0.ebuild b/dev-python/pip-run/pip-run-12.7.0.ebuild
deleted file mode 100644
index f55fab6dd63b..000000000000
--- a/dev-python/pip-run/pip-run-12.7.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Install packages and run Python with them"
-HOMEPAGE="
- https://github.com/jaraco/pip-run/
- https://pypi.org/project/pip-run/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/autocommand[${PYTHON_USEDEP}]
- dev-python/jaraco-context[${PYTHON_USEDEP}]
- dev-python/jaraco-env[${PYTHON_USEDEP}]
- >=dev-python/jaraco-functools-3.7[${PYTHON_USEDEP}]
- dev-python/jaraco-text[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/path-15.1[${PYTHON_USEDEP}]
- >=dev-python/pip-19.3[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- dev-python/flit-core[${PYTHON_USEDEP}]
- dev-python/jaraco-path[${PYTHON_USEDEP}]
- >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest -m "not network"
-}