summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch19
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.6-r3.ebuild (renamed from games-puzzle/xblockout/xblockout-1.1.6-r2.ebuild)8
2 files changed, 23 insertions, 4 deletions
diff --git a/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch b/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch
new file mode 100644
index 000000000000..af322fedd337
--- /dev/null
+++ b/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/899012
+--- a/configure.in
++++ b/configure.in
+@@ -127,6 +127,7 @@ dnl AC_TRY_COMPILE("Prototypes",,extern int y(int z);y(5);}y(z)int z;{,CFLA="$CF
+
+ AC_TEST_PROGRAM([
+ #include <sys/time.h>
++#include <time.h>
+ int main()
+ {
+ fd_set i,j,k ;
+@@ -151,6 +152,7 @@ AC_TEST_PROGRAM([
+ #include <signal.h>
+ #include <stdio.h>
+ #include <sys/time.h>
++#include <unistd.h>
+
+ volatile int c = 0 ;
+ void fct(i) int i ; { c++ ; signal(SIGALRM, fct) ; }
diff --git a/games-puzzle/xblockout/xblockout-1.1.6-r2.ebuild b/games-puzzle/xblockout/xblockout-1.1.6-r3.ebuild
index 914ab6d1ac1c..f433fd8aaccd 100644
--- a/games-puzzle/xblockout/xblockout-1.1.6-r2.ebuild
+++ b/games-puzzle/xblockout/xblockout-1.1.6-r3.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools desktop flag-o-matic toolchain-funcs
DESCRIPTION="X Window block dropping game in 3 Dimension"
HOMEPAGE="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/"
SRC_URI="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/xbl-${PV}.tar.gz"
+S="${WORKDIR}/xbl-${PV}"
LICENSE="GPL-1"
SLOT="0"
@@ -19,10 +20,9 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/xbl-${PV}"
-
PATCHES=(
"${FILESDIR}"/${P}-font.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
)
src_prepare() {