summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/salt/Manifest1
-rw-r--r--app-admin/salt/files/salt-3006-tests.patch74
-rw-r--r--app-admin/salt/files/salt-3006.3-tests.patch26
-rw-r--r--app-admin/salt/salt-3006.3.ebuild237
4 files changed, 264 insertions, 74 deletions
diff --git a/app-admin/salt/Manifest b/app-admin/salt/Manifest
index 5e32f2432539..0a8a5f057bcc 100644
--- a/app-admin/salt/Manifest
+++ b/app-admin/salt/Manifest
@@ -1,3 +1,4 @@
DIST salt-3005.1.tar.gz 17914349 BLAKE2B 697c2068bf119e4a19f92a86ce880fec9375c10ba549cdcdd2182cfeaacce31c7bc4c4c91e1a609906b4c5373bb5e3120e0db47ede5b45ee20942d7b2d201e64 SHA512 391f995f0129f3d7104a0eea4fd83b18aa6ecae0fd7a2c77c1154e24b0bcd52cef4b63db12597c85737bb33ddf605e0c23370cef3bf47f9ea85af5b77d74dc50
DIST salt-3005.2.tar.gz 17935313 BLAKE2B 550853b8245351b251438ac87d775e8b39d71ddc1eee0375f4bb29c04e2aacf5905ef9ac5373d9e7ff47a1cc8d6b9ce1a2a4c3d75b5647d4047bc06a5e526664 SHA512 07e7afc732a97006557d4556d60aa1854934893d0566bf8c295d4b1c01515988a1bf2798ce228f6b37e657de8fdfff51153ad2ea8d54baa6a5c377e30794f317
DIST salt-3006.2.tar.gz 20411634 BLAKE2B dff474017918ef3ee0031856a2739282077205d8c2589809a91e5f1c3741cb26d2bd2458734ea4d3533118c881851dfd853f4ba4f1c631e7db28e95bc1b6f7f8 SHA512 2626cb5beb1b30fc63f554f5804f0d9b7e36b7c569c5f9049e5f5ac5a413e9d99a98b3d91089683338e3d3890ec973dff80782b4e41acb291872e45084fd2546
+DIST salt-3006.3.tar.gz 20461738 BLAKE2B dfa4698dbc611c9c4954b4631d11b685e1efc978915918ce6d8f1890bb4a230d234b6a191166ffff9243058d44530bfc14b43386c8bc295c035c6609d6bf3fa0 SHA512 9cced766db2144de445ed53b52c1551c986ba43774c40512fd07973862d6d3a361e25f55fcfeeb0e03ba44eec1051909834e5d0a352ead5ec6f418b15c909628
diff --git a/app-admin/salt/files/salt-3006-tests.patch b/app-admin/salt/files/salt-3006-tests.patch
deleted file mode 100644
index 6135ca8c0ea1..000000000000
--- a/app-admin/salt/files/salt-3006-tests.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-diff --git a/tests/pytests/unit/modules/test_linux_sysctl.py b/tests/pytests/unit/modules/test_linux_sysctl.py
-index 0bdd24039d..22df70c58d 100644
---- a/tests/pytests/unit/modules/test_linux_sysctl.py
-+++ b/tests/pytests/unit/modules/test_linux_sysctl.py
-@@ -215,7 +215,7 @@ def test_persist_no_conf_failure():
- ):
- with pytest.raises(CommandExecutionError):
- linux_sysctl.persist("net.ipv4.ip_forward", 42, config=None)
-- fopen_mock.called_once()
-+ fopen_mock.assert_called_once()
-
-
- def test_persist_no_conf_success():
-diff --git a/tests/pytests/unit/modules/test_win_ip.py b/tests/pytests/unit/modules/test_win_ip.py
-index 38eb6b1ac5..94a3fe7ca9 100644
---- a/tests/pytests/unit/modules/test_win_ip.py
-+++ b/tests/pytests/unit/modules/test_win_ip.py
-@@ -151,7 +151,7 @@ def test_enable():
- ):
- assert win_ip.enable("Ethernet")
-
-- mock_cmd.called_once_with(
-+ mock_cmd.assert_called_once_with(
- [
- "netsh",
- "interface",
-@@ -180,7 +180,7 @@ def test_disable():
- ):
- assert win_ip.disable("Ethernet")
-
-- mock_cmd.called_once_with(
-+ mock_cmd.assert_called_once_with(
- [
- "netsh",
- "interface",
-diff --git a/tests/pytests/unit/test_master.py b/tests/pytests/unit/test_master.py
-index cd11d217c7..502767d3e3 100644
---- a/tests/pytests/unit/test_master.py
-+++ b/tests/pytests/unit/test_master.py
-@@ -60,7 +60,7 @@ def test_fileserver_duration():
- end = time.time()
- # Interval is equal to timeout so the _do_update method will be called
- # one time.
-- update.called_once()
-+ update.assert_called_once()
- # Timeout is 1 second
- duration = end - start
- if duration > 2 and salt.utils.platform.spawning_platform():
-diff --git a/tests/pytests/unit/utils/event/test_event.py b/tests/pytests/unit/utils/event/test_event.py
-index e289e72dad..2abd4066c4 100644
---- a/tests/pytests/unit/utils/event/test_event.py
-+++ b/tests/pytests/unit/utils/event/test_event.py
-@@ -300,7 +300,7 @@ def test_connect_pull_should_debug_log_on_StreamClosedError():
- event = SaltEvent(node=None)
- with patch.object(event, "pusher") as mock_pusher:
- with patch.object(
-- salt.utils.event.log, "debug", auto_spec=True
-+ salt.utils.event.log, "debug", auto_spec=True, unsafe=True
- ) as mock_log_debug:
- mock_pusher.connect.side_effect = (
- salt.ext.tornado.iostream.StreamClosedError
-@@ -317,10 +317,10 @@ def test_connect_pull_should_error_log_on_other_errors(error):
- event = SaltEvent(node=None)
- with patch.object(event, "pusher") as mock_pusher:
- with patch.object(
-- salt.utils.event.log, "debug", auto_spec=True
-+ salt.utils.event.log, "debug", auto_spec=True, unsafe=True
- ) as mock_log_debug:
- with patch.object(
-- salt.utils.event.log, "error", auto_spec=True
-+ salt.utils.event.log, "error", auto_spec=True, unsafe=True
- ) as mock_log_error:
- mock_pusher.connect.side_effect = error
- event.connect_pull()
diff --git a/app-admin/salt/files/salt-3006.3-tests.patch b/app-admin/salt/files/salt-3006.3-tests.patch
new file mode 100644
index 000000000000..4d30608775cb
--- /dev/null
+++ b/app-admin/salt/files/salt-3006.3-tests.patch
@@ -0,0 +1,26 @@
+diff --git a/tests/pytests/unit/utils/event/test_event.py b/tests/pytests/unit/utils/event/test_event.py
+index e289e72dad..2abd4066c4 100644
+--- a/tests/pytests/unit/utils/event/test_event.py
++++ b/tests/pytests/unit/utils/event/test_event.py
+@@ -300,7 +300,7 @@ def test_connect_pull_should_debug_log_on_StreamClosedError():
+ event = SaltEvent(node=None)
+ with patch.object(event, "pusher") as mock_pusher:
+ with patch.object(
+- salt.utils.event.log, "debug", auto_spec=True
++ salt.utils.event.log, "debug", auto_spec=True, unsafe=True
+ ) as mock_log_debug:
+ mock_pusher.connect.side_effect = (
+ salt.ext.tornado.iostream.StreamClosedError
+@@ -317,10 +317,10 @@ def test_connect_pull_should_error_log_on_other_errors(error):
+ event = SaltEvent(node=None)
+ with patch.object(event, "pusher") as mock_pusher:
+ with patch.object(
+- salt.utils.event.log, "debug", auto_spec=True
++ salt.utils.event.log, "debug", auto_spec=True, unsafe=True
+ ) as mock_log_debug:
+ with patch.object(
+- salt.utils.event.log, "error", auto_spec=True
++ salt.utils.event.log, "error", auto_spec=True, unsafe=True
+ ) as mock_log_error:
+ mock_pusher.connect.side_effect = error
+ event.connect_pull()
diff --git a/app-admin/salt/salt-3006.3.ebuild b/app-admin/salt/salt-3006.3.ebuild
new file mode 100644
index 000000000000..af77b214d420
--- /dev/null
+++ b/app-admin/salt/salt-3006.3.ebuild
@@ -0,0 +1,237 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_10 )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit systemd distutils-r1
+
+DESCRIPTION="Salt is a remote execution and configuration manager"
+HOMEPAGE="https://www.saltstack.com/resources/community/
+ https://github.com/saltstack"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}stack/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="
+ cheetah cherrypy ldap libcloud libvirt genshi gnupg keyring mako
+ mongodb neutron nova openssl portage profile redis selinux test raet
+ +zeromq vim-syntax
+"
+
+RDEPEND="
+ sys-apps/pciutils
+ >=dev-python/cryptography-41.0.3[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/libnacl[${PYTHON_USEDEP}]
+ dev-python/looseversion[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.9.8[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0.1[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ libcloud? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/aiosignal[${PYTHON_USEDEP}]
+ >=dev-python/apache-libcloud-2.5.0[${PYTHON_USEDEP}]
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ )
+ mako? ( dev-python/mako[${PYTHON_USEDEP}] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
+ libvirt? (
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ )
+ openssl? (
+ dev-libs/openssl:0=[-bindist(-)]
+ >=dev-python/pyopenssl-23.2.0[${PYTHON_USEDEP}]
+ )
+ raet? (
+ >=dev-python/libnacl-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ioflo-1.1.7[${PYTHON_USEDEP}]
+ >=dev-python/raet-0.6.0[${PYTHON_USEDEP}]
+ )
+ cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] )
+ cheetah? ( >=dev-python/cheetah3-3.2.2[${PYTHON_USEDEP}] )
+ genshi? ( dev-python/genshi[${PYTHON_USEDEP}] )
+ mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+ portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
+ keyring? ( dev-python/keyring[${PYTHON_USEDEP}] )
+ redis? ( dev-python/redis[${PYTHON_USEDEP}] )
+ selinux? ( sec-policy/selinux-salt )
+ nova? (
+ >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}]
+ )
+ neutron? (
+ >=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}]
+ )
+ gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
+ profile? ( dev-python/yappi[${PYTHON_USEDEP}] )
+ vim-syntax? ( app-vim/salt-vim )
+ zeromq? ( >=dev-python/pyzmq-19.0.0[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/apache-libcloud[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.32.1[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2023.07.22[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/moto-2.0.0[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-salt-factories-1.0.0_rc25[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ dev-python/pytest-shell-utilities[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+ dev-python/pytest-system-statistics[${PYTHON_USEDEP}]
+ dev-python/pytest-custom-exit-code[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ net-dns/bind-tools
+ >=dev-python/virtualenv-20.3.0[${PYTHON_USEDEP}]
+ dev-util/yamllint[${PYTHON_USEDEP}]
+ !x86? ( >=dev-python/boto3-1.21.46[${PYTHON_USEDEP}] )
+ )
+"
+
+DOCS=( README.rst AUTHORS )
+
+REQUIRED_USE="|| ( raet zeromq )
+ test? ( cheetah genshi )"
+RESTRICT="!test? ( test ) x86? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/salt-3003-gentoolkit-revdep.patch"
+ "${FILESDIR}/salt-3005.1-no-entry-points.patch"
+ "${FILESDIR}/salt-3006-skip-tests-that-oom-machine.patch"
+ "${FILESDIR}/salt-3006.2-tests.patch"
+ "${FILESDIR}/salt-3006.3-tests.patch"
+)
+
+python_prepare_all() {
+ # remove tests with external dependencies that may not be available, and
+ # tests that don't work in sandbox
+ rm tests/unit/{test_{zypp_plugins,module_names},utils/test_extend}.py || die
+ rm tests/unit/modules/test_boto_{vpc,secgroup,elb}.py || die
+ rm tests/unit/states/test_boto_vpc.py || die
+
+ #rm tests/support/gitfs.py || die
+ rm tests/pytests/functional/transport/server/test_req_channel.py || die
+ rm tests/pytests/functional/utils/test_async_event_publisher.py || die
+ rm tests/pytests/functional/runners/test_winrepo.py || die
+ rm tests/unit/netapi/rest_tornado/test_saltnado.py || die
+
+ # tests that require network access
+ rm tests/unit/{states,modules}/test_zcbuildout.py || die
+ rm -r tests/integration/cloud || die
+ rm -r tests/kitchen/tests/wordpress/tests || die
+ rm tests/kitchen/test_kitchen.py || die
+ rm tests/unit/modules/test_network.py || die
+ rm tests/pytests/functional/modules/test_pip.py || die
+ rm tests/pytests/unit/client/ssh/test_ssh.py || die
+ rm -r tests/pytests/{integration,functional}/netapi tests/integration/netapi || die
+
+ # tests require root access
+ rm tests/integration/pillar/test_git_pillar.py || die
+ rm tests/integration/states/test_supervisord.py || die
+
+ # removes contextvars, see bug: https://bugs.gentoo.org/799431
+ sed -i '/^contextvars/d' requirements/base.txt || die
+
+ # make sure pkg_resources doesn't bomb because pycrypto isn't installed
+ find "${S}" -name '*.txt' -print0 | xargs -0 sed -e '/pycrypto>/ d ; /pycryptodomex/ d' -i || die
+ # pycryptodome rather than pycryptodomex
+ find "${S}" -name '*.py' -print0 | xargs -0 -- sed -i -e 's:Cryptodome:Crypto:g' -- || die
+ # called_once should be assert_called_once_with
+ find "${S}/tests" -name '*.py' -print0 | xargs -0 -- sed -i -e 's:[.]called_once:.assert_called_once:g' -- || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local svc
+ USE_SETUPTOOLS=1 distutils-r1_python_install_all
+
+ for svc in minion master syndic api; do
+ newinitd "${FILESDIR}"/${svc}-initd-5 salt-${svc}
+ newconfd "${FILESDIR}"/${svc}-confd-1 salt-${svc}
+ systemd_dounit "${FILESDIR}"/salt-${svc}.service
+ done
+
+ insinto /etc/${PN}
+ doins -r conf/*
+}
+
+python_test() {
+ local -a EPYTEST_DESELECT=(
+ # doesn't like the distutils warning
+ tests/pytests/integration/cli/test_batch.py::test_batch_retcode
+ tests/pytests/integration/cli/test_batch.py::test_multiple_modules_in_batch
+ # hangs indefinitely
+ tests/pytests/unit/test_minion.py::test_master_type_disable
+ # needs root
+ tests/pytests/unit/modules/test_cmdmod.py::test_runas_env_sudo_group
+ # don't like sandbox
+ tests/pytests/functional/cli/test_salt.py::test_versions_report
+ tests/unit/utils/test_vt.py::test_split_multibyte_characters_unicode
+ tests/unit/utils/test_vt.py::test_split_multibyte_characters_shiftjis
+ tests/pytests/unit/utils/test_vt.py::test_log_sanitize
+ tests/pytests/unit/client/ssh/test_single.py::test_run_with_pre_flight_args
+ tests/pytests/unit/modules/test_aptpkg.py::test_call_apt_dpkg_lock
+ tests/pytests/unit/test_master.py::test_fileserver_duration
+ tests/pytests/unit/test_template.py::test_compile_template_str_mkstemp_cleanup
+ tests/pytests/unit/_logging/handlers/test_deferred_stream_handler.py::test_deferred_write_on_flush
+ tests/pytests/unit/_logging/handlers/test_deferred_stream_handler.py::test_sync_with_handlers
+ tests/pytests/unit/modules/test_portage_config.py::test_enforce_nice_config
+ tests/pytests/unit/modules/test_msteams.py::test_post_card
+ tests/pytests/unit/states/test_file.py::test_file_recurse_directory_test
+ tests/unit/utils/test_schema.py::ConfigTestCase::test_anyof_config_validation
+ tests/unit/utils/test_schema.py::ConfigTestCase::test_dict_config_validation
+ tests/unit/utils/test_schema.py::ConfigTestCase::test_hostname_config_validation
+ tests/unit/utils/test_schema.py::ConfigTestCase::test_not_config_validation
+ tests/unit/utils/test_schema.py::ConfigTestCase::test_oneof_config_validation
+ tests/unit/utils/test_schema.py::ConfigTestCase::test_optional_requirements_config_validation
+ )
+
+ # testsuite likes lots of files
+ ulimit -n 4096 || die
+
+ # ${T} is too long a path for the tests to work
+ local TMPDIR
+ TMPDIR="$(mktemp --directory --tmpdir=/tmp ${PN}-XXXX)" || die
+ (
+ export TMPDIR
+ cleanup() { rm -rf "${TMPDIR}" || die; }
+
+ trap cleanup EXIT
+
+ addwrite "${TMPDIR}"
+
+ USE_SETUPTOOLS=1 NO_INTERNET=1 SHELL="/bin/bash" \
+ epytest
+ )
+}