summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/pwstore-fast/metadata.xml13
-rw-r--r--dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild7
2 files changed, 3 insertions, 17 deletions
diff --git a/dev-haskell/pwstore-fast/metadata.xml b/dev-haskell/pwstore-fast/metadata.xml
index cdbf6fd8bacc..b7878815d80d 100644
--- a/dev-haskell/pwstore-fast/metadata.xml
+++ b/dev-haskell/pwstore-fast/metadata.xml
@@ -5,17 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- To store passwords securely, they should be salted,
- then hashed with a slow hash function. This library
- uses PBKDF1-SHA256, and handles all the details.
- It uses the cryptohash package for speed; if you need
- a pure Haskell library, pwstore-purehaskell has the
- exact same API, but uses only pure Haskell. It is
- about 25 times slower than this package, but still
- quite usable.
- </longdescription>
- <upstream>
- <remote-id type="github">PeterScott/pwstore</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild b/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild
index c285f1a28c89..1303a14bfc7d 100644
--- a/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild
+++ b/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.4.4.9999
+# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -18,7 +18,6 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/base64-bytestring-0.1:=[profile?]
- >=dev-haskell/binary-0.5:=[profile?]
>=dev-haskell/byteable-0.1:=[profile?]
>=dev-haskell/cryptohash-0.6:=[profile?]
>=dev-haskell/random-1:=[profile?]