summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-13 17:14:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-13 17:14:52 +0200
commite4f640dacccb1a05bf1e2de62ed3f0f4fe66ee3b (patch)
treed8c14d9ef7083a3ec158398494ec0a54fcd8e074 /xfce-base
parentdev-util/pkgconf: add support for windows (diff)
downloadgentoo-e4f640dacccb1a05bf1e2de62ed3f0f4fe66ee3b.tar.gz
gentoo-e4f640dacccb1a05bf1e2de62ed3f0f4fe66ee3b.tar.bz2
gentoo-e4f640dacccb1a05bf1e2de62ed3f0f4fe66ee3b.zip
xfce-base/libxfce4ui: Backport keyboard shortcut dialog fix
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/files/libxfce4ui-4.15.3-kb-shortcut.patch38
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.15.3-r1.ebuild (renamed from xfce-base/libxfce4ui/libxfce4ui-4.15.3.ebuild)4
2 files changed, 42 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/files/libxfce4ui-4.15.3-kb-shortcut.patch b/xfce-base/libxfce4ui/files/libxfce4ui-4.15.3-kb-shortcut.patch
new file mode 100644
index 000000000000..bfce065fdef4
--- /dev/null
+++ b/xfce-base/libxfce4ui/files/libxfce4ui-4.15.3-kb-shortcut.patch
@@ -0,0 +1,38 @@
+From 0fc934ebee037a91e032d362d83d991309c4ce88 Mon Sep 17 00:00:00 2001
+From: Harald Judt <h.judt@gmx.at>
+Date: Sat, 4 Jul 2020 00:22:31 +0200
+Subject: [PATCH] Always return GTK_RESPONSE_OK for accepted shortcut keys
+ (fixes #20)
+
+Commit a41dcb19 replaced the deprecated gtk_keyboard_ungrab code but
+also erroneously put the gtk_dialog_response call inside the
+gdk_seat_grab check, while it should be inside the shortcut_accepted
+check. This commit restores the original logic, thus properly setting
+the accepted shortcut key and closing the dialog.
+
+Closes !4
+---
+ libxfce4kbd-private/xfce-shortcut-dialog.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/libxfce4kbd-private/xfce-shortcut-dialog.c b/libxfce4kbd-private/xfce-shortcut-dialog.c
+index 427855a..ae9c195 100644
+--- a/libxfce4kbd-private/xfce-shortcut-dialog.c
++++ b/libxfce4kbd-private/xfce-shortcut-dialog.c
+@@ -424,10 +424,10 @@ xfce_shortcut_dialog_key_released (XfceShortcutDialog *dialog,
+ TRUE, NULL, NULL, NULL, NULL))
+ {
+ gdk_seat_ungrab (seat);
+-
+- /* Exit dialog with positive response */
+- gtk_dialog_response (GTK_DIALOG (dialog), GTK_RESPONSE_OK);
+ }
++
++ /* Exit dialog with positive response */
++ gtk_dialog_response (GTK_DIALOG (dialog), GTK_RESPONSE_OK);
+ }
+ else
+ {
+--
+2.26.2
+
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.15.3.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.15.3-r1.ebuild
index cddd13c8d5ef..9d9f9229dd38 100644
--- a/xfce-base/libxfce4ui/libxfce4ui-4.15.3.ebuild
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.15.3-r1.ebuild
@@ -33,6 +33,10 @@ BDEPEND="dev-lang/perl
virtual/pkgconfig
vala? ( $(vala_depend) )"
+PATCHES=(
+ "${FILESDIR}"/${P}-kb-shortcut.patch
+)
+
src_prepare() {
# stupid vala.eclass...
default