summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-18 23:29:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-18 23:34:29 +0200
commit72f0a4de3ebd9dac4706496bad9ac5fb8668cb35 (patch)
tree65d2ac258125edf0293bc754d935740e0769339c /xfce-base/garcon/garcon-0.7.1.ebuild
parentwww-client/opera: Old (diff)
downloadgentoo-72f0a4de3ebd9dac4706496bad9ac5fb8668cb35.tar.gz
gentoo-72f0a4de3ebd9dac4706496bad9ac5fb8668cb35.tar.bz2
gentoo-72f0a4de3ebd9dac4706496bad9ac5fb8668cb35.zip
xfce-base/garcon: Bump to 0.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/garcon/garcon-0.7.1.ebuild')
-rw-r--r--xfce-base/garcon/garcon-0.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/xfce-base/garcon/garcon-0.7.1.ebuild b/xfce-base/garcon/garcon-0.7.1.ebuild
new file mode 100644
index 000000000000..4c3203735172
--- /dev/null
+++ b/xfce-base/garcon/garcon-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="https://docs.xfce.org/xfce/exo/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection"
+
+RDEPEND=">=dev-libs/glib-2.30
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/libxfce4util-4.15.2:=[introspection?]
+ >=xfce-base/libxfce4ui-4.15.2:=[introspection?]
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}